mozicon16.xpm missing -> mozilla (gtk build) crashes on startup

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: James Henstridge, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
If the mozicon16.xpm file is not found in the icons subdirectory, mozilla will
crash when it tries to dereference a NULL GdkPixmap pointer.  Fix is fairly
simple, and patch to follow.
(Reporter)

Comment 1

17 years ago
Created attachment 55163 [details] [diff] [review]
add extra checks when setting the window's icon to prevent crashes.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1

Comment 2

16 years ago
--> default owner
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0.1 → ---

Comment 3

16 years ago
Hmm. Seems reasonable for robustness (although I don't know how common it is 
that that icon would go "missing"). Should we check this in? (Sorry that this
just lay here so long).
(Reporter)

Comment 4

16 years ago
I ran into this problem when I was working on Komodo.  I changed the filename it
would use for the icons, but forgot to put the new icons in the right place.

The code for setting the main icon would spit out a few warnings when the file
was missing, but the mini-icon code happily dereference the NULL pointers.  It
isn't a very important bug, but it would be nice to handle this error condition
better.

Updated

9 years ago
Assignee: jag → nobody

Comment 5

8 years ago
This code has changed a lot since 2002.  I think the problem is gone.

http://mxr.mozilla.org/mozilla-central/source/widget/src/gtk2/nsWindow.cpp#1803
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.