bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Problems with style interpretation and visibility

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Stephen Lee, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Firstly the styles for the different states of the example do not behave as 
expected.  They behave perfectly well when using IE and this is a very simple 
example.

Secondly the "Hide" functionality works initially, but not on subsequent 
activation after the "Show" functionality has been run.  This is inconsistent 
within itself.
I see the Show/Hide problem.  Could you describe the actual vs. expected results
for the first problem more clearly?  Also, you're better off submitting one
issue per bug, because if you don't the bug will become focused on one of the
issues (particularly if the two separate bugs would have been assigned to
different people) and the other will be ignored.
I got this email.  In the future, please comment on the bug.
---
Date: Fri, 26 Oct 2001 12:39:38 +1000
From: Stephen Lee <Stephen@stsuit.com.au>
To: dbaron@fas.harvard.edu
Subject: Re: Bug 106835

If you open up the page with IE you will se the expected results:

As an example if you move the mouse over the toolbar options the
background color becomes white and the font color black.  The font size
remains constant.

I take note of you comment about splitting the bug report and will
endeavour to do so in future.

Many thanks
Steve Lee
Ths show/hide problem is bug 97874 (the issue is a set of block elements inside
a span that gets its display property toggled).

Of the rest, I've looked through the sheet and played with the page.  The
toolbar works for me exactly how you describe -- I get black text on white
background in the same size.  That's consistent with the stylesheet.

The only part of the sheet we obviously do not render is "cursor: hand" which is
an MSIE-ism.  The correct css way to express that is "cursor: pointer"

I don't have IE (and don't have access to any computers it would run on....). 
So Stephen, could you please provide a clear description of how IE and Mozilla's
behavior differ?  Thanks for your time.....
(Reporter)

Comment 4

17 years ago
I did try to attach two images.  One of the style under IE5 and one under NS6, 
unfortunately this software did not work correctly and I am unable to do so.  I 
have reported the error to your webmaster.

On my Netscape browser (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 
rv:0.9.2) Gecko/20010726 Netscape6/6.1) the toobar style on mouseover gives a 
transparent background and a non-bold font unlike the specified white 
background with bold font in the style sheet.  There is also a huge lime green 
margin around the displayed popup.

I recognise the issue with the cursor styles.

By the way.... there is no need to get snotty with me.  I am just close enough 
to drop Netscape as an option from any future development for my company.  I am 
a professional and expect a professional response from you.
> By the way.... there is no need to get snotty with me.

I wasn't trying to.  I apologize if you perceived it that way.  I think it's in
both our best interests to figure out what the problem is here.

Could you possibly try a recent milestone (say 0.9.5) and see whether the bug
persists?  It may well have been fixed since Netscape 6.1.

I'll attach a screenshot of what I see with a current build.  It does not
include hover effects due to the limitations of the focus model on Linux, but I
do see bold text on a white background when I hover over the toolbar.
Comment on attachment 55233 [details]
Screenshot

Um.  Wrong image.
Attachment #55233 - Attachment is obsolete: true
(Reporter)

Comment 9

17 years ago
The real screenshot does not depict any of the "Option" fields, however the 
yellow area around the popup selections should not be present.

I would show you, but I am still unable to create an attachment.

How do I get hold of 0.9.5?
The yellow is there as a consequence of the following rules in the stylesheet:

.PopUpTable
{
    PADDING-RIGHT: 8px;
    PADDING-LEFT: 8px;
    PADDING-BOTTOM: 4px;
    PADDING-TOP: 4px;
    BACKGROUND-COLOR: yellow
}

since padding areas get painted with the background.

0.9.5 is available from http://mozilla.org/releases/; scroll down the page a
little bit to get to the download links (they should really have a named anchor
there....).
(Reporter)

Comment 11

17 years ago
Many thanks for that.  I now have to chase up Microsoft to see why IE did not 
follow what was in the stylesheet.

I double checked the stylesheet section for Options and that was correct, so I 
will now try version 0.9.5.

Once again thanks.
Could someone summarize the remaining issues here that are bugs in Mozilla?
(Reporter)

Comment 13

17 years ago
I have tried Mozilla 5 build 0.9.5 which works as expected.  The problem has 
been fixed, but not yet applied to Netscape 6.1.

Thank you for your efforts in this regard.
Severity: blocker → normal
ok, then marking worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.