Closed Bug 1068351 Opened 5 years ago Closed 5 years ago

Crash in PK11_DoesMechanism due to race condition

Categories

(NSS :: Libraries, defect)

3.15.4
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1050069

People

(Reporter: elio.maldonado.batiz, Assigned: rrelyea)

References

Details

Attachments

(1 file)

Problem  originally reported by Marc Sauton: 
Red Hat Directory Server/RHDS 9.1 user reports a crash in Crash in PK11_DoesMechanism Environment is RHEL 6.5 in a heavily used environment

The crash appear to be in libnss3.so, for a RHDS / LDAP server replication incremental update over SSL using basic auth for the DN configured to LDAP BIND to the remote system, uid=redacted,cn=config (redacted cred), using SASL, from system called ldap5 to another RHDS LDAP server called ldap6, in a SSLv3 client hello handshake.

Core was generated by `/usr/sbin/ns-slapd -D /etc/dirsrv/slapd-ldap5 -i /var/run/dirsrv/slapd-ldap5.pi'. Program terminated with signal 11, Segmentation fault.

The problem was analyzed and solved by Bob Relyea whose patch I'm attaching adapted for the current sources.
Attachment #8490417 - Flags: review?(wtc)
Assignee: nobody → rrelyea
Comment on attachment 8490417 [details] [diff] [review]
Fix for race conditions

Review of attachment 8490417 [details] [diff] [review]:
-----------------------------------------------------------------

I seem to remember I reviewed this patch before. Is this patch
also attached to another bug?  Or perhaps I forgot to press the
"Publish" button last time I review this patch :-(
You are right and what you reviewed is the patch for Bug 1050069. This is actually a supplement to that other bug for you have proposed an alternative. As I am preparing a downstream build with the alternative for the LDAP team to test per https://bugzilla.mozilla.org/show_bug.cgi?id=1050069#c17, I examined the rhel-7 nss.spec file and notice two patches with references to that bug. It happens that the first patch caused a race condition and that's why we needed this second one. 

Once we get feedback that the alternative fix works and you get to check it and in the future we pick it up for RHEL then the two patches will go away. Mystery solved, or so I think. In due time I'll close this bug as a duplicate of the other one.
Wan-Teh, The mystery may be solved but the problem hasn't been solved. I'll attach this patch to the other bug, as an addendum to your proposed alternative patch, for you and Bob to review there.
Sorry for all the confusion, problem should be solved by the new alternative patch for Bug 1050069 now under consideration.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050069
Attachment #8490417 - Flags: review?(wtc)
See Also: → 1054373
You need to log in before you can comment on or make changes to this bug.