mouseover / hover emulation needed on Android for many websites

RESOLVED DUPLICATE of bug 460966

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 460966
4 years ago
2 years ago

People

(Reporter: kolAflash, Unassigned)

Tracking

32 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 2014091200

Steps to reproduce:

Many websites use menus which open up on mouseover/hover over a button. Those menus aren't accessible in Firefox for Android (tested with Firefox 32.0.1 on Android 4.4.4) because there's no way to trigger a mouseover.


Example websites:

https://addons.mozilla.org The "$USERNAME" menu when logged in isn't accessible. When clicking it, it opens up for half a second but then the site reloads and the menu is gone again. The "Tools" menu (also when logged in) and the "Other Applications" menu act a little different. Clicking them triggers an unnecessary site reload but afterwards they stay opened.

https://www.schiffszimmerer.de
Menus on the top like "Mitgliederservice" are not accessible.

http://hamburg.gruene.de
Menu at the button "Mitmachen" isn't accessible.


Dolphin Browser (on Android) solved it this way. Instead off just clicking you move your finger just a few millimetres and it triggers mouse-over instead. Would love that on Firefox as well.
https://play.google.com/store/apps/details?id=mobi.mgeek.TunnyBrowser&hl=de

In Chrome for Android (Chrome 36.0.1985.128 on Android 4.4.4) you can long-press such a menu-button. That brings up the websites menu and the standard Chrome menu (open in new tab, save link, ...) at the same time, with the Chrome menu staying in foreground. But after pressing the "back" key on my phone or just tapping somewhere else on the screen the Chrome menu closes and I can access the opened up websites menu.


Nevertheless, if this kind of menu is a bad website behaviour or not, other mobile browsers handle this issue (as described). There are some websites out there with this problem and so I and probably a lot of other people are being constantly forced to use another mobile browser because of this.

Please consider to implement it the way Chrome and Dolphin for Android did it!

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460966

Comment 2

2 years ago
This is the more generic bug, shouldn't that be the dupe?
It's not that anyone is working on this since 2010.
No. The older bug has many comments that would be lost by duping to the newer bug. Unless there is a really good reason the older bug wins. Here are some cases where duping to the newer bug. If the newer bug is fixed it would make sense to dupe to the newer bug or the newer bug has good discussion from developers and the older does not have much discussion. If you wish to continue this discussion please email me directly, a bug is not a great place for such a discussion of policies.
You need to log in before you can comment on or make changes to this bug.