Assertion failure: IsOnOwningThread() in Blob.cpp line 334

RESOLVED DUPLICATE of bug 1068326

Status

()

Core
DOM: Content Processes
RESOLVED DUPLICATE of bug 1068326
3 years ago
3 years ago

People

(Reporter: dhylands, Assigned: khuey)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I built a debug build of the latest master (changeset changeset:   205553:8172d2934c45 on b2g-inbound)

and a few seconds after the home screen appears, it crashes (it also crashes if I just leave it on the lock screen):

> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 1358.1821]
> 0xb4e0b534 in AssertIsOnOwningThread (this=<optimized out>) at ../../../b2g-inbound/dom/ipc/Blob.cpp:334
> 334	    MOZ_ASSERT(IsOnOwningThread());
> (gdb) bt
> #0  0xb4e0b534 in AssertIsOnOwningThread (this=<optimized out>) at ../../../b2g-inbound/dom/ipc/Blob.cpp:334
> #1  (anonymous namespace)::RemoteInputStream::AssertIsOnOwningThread (this=<optimized out>) at ../../../b2g-inbound/dom/ipc/Blob.cpp:332
> #2  0xb4e0b954 in (anonymous namespace)::RemoteInputStream::BlockAndGetInternalStream (this=0xab5129a0) at ../../../b2g-inbound/dom/ipc/Blob.cpp:521
> #3  0xb4e0d194 in mozilla::dom::BlobParent::OpenStreamRunnable::OpenStream (this=0xab51beb0) at ../../../b2g-inbound/dom/ipc/Blob.cpp:769
> #4  0xb43f590c in nsThread::ProcessNextEvent (this=0xb0bbafb0, aMayWait=<optimized out>, aResult=0xa9fc7e27) at ../../../b2g-inbound/xpcom/threads/nsThread.cpp:823
> #5  0xb4409eac in NS_ProcessNextEvent (aThread=0xb0bbafb0, aMayWait=<optimized out>) at /home/work/B2G-flame/b2g-inbound/xpcom/glue/nsThreadUtils.cpp:265
> #6  0xb45bc7b0 in mozilla::ipc::MessagePumpForNonMainThreads::Run (this=0xab51be50, aDelegate=0xae303a60) at ../../../b2g-inbound/ipc/glue/MessagePump.cpp:339
> #7  0xb45aa7d2 in MessageLoop::RunInternal (this=0xae303a60) at ../../../b2g-inbound/ipc/chromium/src/base/message_loop.cc:234
> #8  0xb45aa7ea in RunHandler (this=0xae303a60) at ../../../b2g-inbound/ipc/chromium/src/base/message_loop.cc:227
> #9  MessageLoop::Run (this=0xae303a60) at ../../../b2g-inbound/ipc/chromium/src/base/message_loop.cc:201
> #10 0xb43f6a10 in nsThread::ThreadFunc (aArg=0xb0bbafb0) at ../../../b2g-inbound/xpcom/threads/nsThread.cpp:350
> #11 0xb697f848 in _pt_root (arg=0xac326580) at ../../../../../b2g-inbound/nsprpub/pr/src/pthreads/ptthread.c:212
> #12 0xb6e7fba4 in __thread_entry (func=0xb697f7a1 <_pt_root>, arg=0xac326580, tls=0xa9fc7f00) at bionic/libc/bionic/pthread_create.cpp:92
> #13 0xb6e7fd20 in pthread_create (thread_out=0xbea5f3c4, attr=<optimized out>, start_routine=0x78, arg=0xac326580) at bionic/libc/bionic/pthread_create.cpp:201
> #14 0x00000000 in ?? ()

Comment 1

3 years ago
not an IPC bug.
Component: IPC → DOM: Content Processes
Kyle has this patched already.
Assignee: nobody → khuey
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068326
You need to log in before you can comment on or make changes to this bug.