If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[soft-home-button] SHB missing when opening browser in landscape mode

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ericcc, Assigned: Eli)

Tracking

(Depends on: 1 bug)

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8490543 [details]
BrowserLandscape.png

### STR
1. Turn on soft home button on Flame
2. Open Browser in landscape mode

### Actual
Black bar missing, background shown
See BrowserLandscape.png

### Version
Gaia      47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/e20869e87e23
BuildID   20140916160202
Version   34.0a2
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=Gaia::System]
status-b2g-v2.1: --- → affected
(Reporter)

Comment 1

3 years ago
Same in Video(landscape), Gallery(landscape)
Camera is okay
(Assignee)

Updated

3 years ago
Assignee: nobody → eperelman
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S5 (26sep)
(Assignee)

Comment 2

3 years ago
Created attachment 8490825 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24143

This bug was caused by the patch in bug 1064595 which broke the CSS specificity of the landscape mode styles.
Attachment #8490825 - Flags: review?(kgrandon)
Comment on attachment 8490825 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24143

Looks good to me.
Attachment #8490825 - Flags: review?(kgrandon) → review+
Updated commit to include reviewer and landed: https://github.com/mozilla-b2g/gaia/commit/388f623f7f44277571b22dc13e670f25cd54ae32
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-v2.2: --- → fixed
(Assignee)

Comment 5

3 years ago
Comment on attachment 8490825 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24143

Requesting uplift to v2.1 for SHB broken UX while in landscape

[Bug caused by] (feature/regressing bug #): bug 1064595
[User impact] if declined: invisible SHB while in landscape mode
[Testing completed]: yes, manual and automated
[Risk to taking this patch] (and alternatives if risky): negligible
[String changes made]: n/a
Attachment #8490825 - Flags: approval-gaia-v2.1?
Broken feature.
blocking-b2g: --- → 2.1+
Comment on attachment 8490825 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24143

I don't see any automated test in this bug. Is it filed somewhere else?
Attachment #8490825 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
(Assignee)

Comment 8

3 years ago
Apologies, I misunderstood what the "Testing completed" field meant. To clarify, no additional tests were written for this, only that I manually tested the patch myself and it passed all the existing automated tests.
v2.1: https://github.com/mozilla-b2g/gaia/commit/d762b80608959fd387ac95d93ad3b521879d7ddc
status-b2g-v2.1: affected → fixed
(Reporter)

Comment 10

3 years ago
Gaia-Rev        b542080231bb9cdbdb282ab926965ad3f91f7460
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/d614ae398c03
Build-ID        20140923155123
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
Status: RESOLVED → VERIFIED
Issue verified as fixed on Flame 2.1 & Flame 2.2

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master  KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

With Software Home Button enabled, the SHB is always visible in landscape mode for Browser, Gallery, and Video app
QA Whiteboard: [COM=Gaia::System] → [COM=Gaia::System][QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::System][QAnalyst-Triage?] → [COM=Gaia::System][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

3 years ago
Flags: in-testsuite?
Setting testsuite- for bugs which depend on landscape b2g desktop for testing. This list will be re-triaged once support is added.
Depends on: 1080309
Flags: in-testsuite? → in-testsuite-
You need to log in before you can comment on or make changes to this bug.