Intermittent toblob-quality-undefined.html | application crashed [@ gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double)]

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound opt test reftest on 2014-09-16 22:57:48 PDT for push f4123c7172ee

slave: talos-mtnlion-r5-005

https://tbpl.mozilla.org/php/getParsedLog.php?id=48262870&tree=Mozilla-Inbound

23:20:00  WARNING -  PROCESS-CRASH | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/content/html/content/reftests/toblob-todataurl/toblob-quality-undefined.html | application crashed [@ gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double)]
23:20:00     INFO -  Crash dump filename: /var/folders/dm/7m667lqs14x98bc9yr9nz29h00000w/T/tmppdCa7J.mozrunner/minidumps/353500E2-BE93-4980-82CB-85DF713F5217.dmp
23:20:00     INFO -  Operating system: Mac OS X
23:20:00     INFO -                    10.8.0 12A269
23:20:00     INFO -  CPU: amd64
23:20:00     INFO -       family 6 model 42 stepping 7
23:20:00     INFO -       8 CPUs
23:20:00     INFO -  Crash reason:  EXC_BAD_ACCESS / 0x0000000d
23:20:00     INFO -  Crash address: 0x0
23:20:00     INFO -  Thread 0 (crashed)
23:20:00     INFO -   0  XUL!gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double) [gfxDrawable.cpp:f4123c7172ee : 43 + 0x3]
23:20:00     INFO -      rbx = 0x0000000000000000   r12 = 0x0000000000000140
23:20:00     INFO -      r13 = 0x000000011c669f10   r14 = 0x0000000000000000
23:20:00     INFO -      r15 = 0x00000000000000f0   rip = 0x0000000101e5743c
23:20:00     INFO -      rsp = 0x00007fff5fbfa570   rbp = 0x00007fff5fbfa620
23:20:00     INFO -      Found by: given as instruction pointer in context
23:20:00     INFO -   1  XUL!gfxUtils::DrawPixelSnapped(gfxContext*, gfxDrawable*, gfxSize const&, mozilla::image::ImageRegion const&, mozilla::gfx::SurfaceFormat, GraphicsFilter, unsigned int, double) [gfxUtils.cpp:f4123c7172ee : 597 + 0x1e]
23:20:00     INFO -      rbx = 0x000000011c669f10   r12 = 0x00007fff5fbfa920
23:20:00     INFO -      r13 = 0x0000000112487e00   r14 = 0x0000000000000000
23:20:00     INFO -      r15 = 0x00007fff5fbfa900   rip = 0x0000000101e99c6a
23:20:00     INFO -      rsp = 0x00007fff5fbfa630   rbp = 0x00007fff5fbfa8a0
23:20:00     INFO -      Found by: call frame info
23:20:00     INFO -   2  XUL!mozilla::image::imgFrame::Draw(gfxContext*, mozilla::image::ImageRegion const&, nsIntMargin const&, GraphicsFilter, unsigned int) [imgFrame.cpp:f4123c7172ee : 519 + 0x3f]
23:20:00     INFO -      rbx = 0x000000011c669f10   r12 = 0x000000011272ef20
23:20:00     INFO -      r13 = 0x00007fff5fbfaa78   r14 = 0x00000001163c59c0
23:20:00     INFO -      r15 = 0x0000000112487e00   rip = 0x0000000101ed131f
23:20:00     INFO -      rsp = 0x00007fff5fbfa8b0   rbp = 0x00007fff5fbfa9f0
23:20:00     INFO -      Found by: call frame info
23:20:00     INFO -   3  XUL!mozilla::image::RasterImage::DrawWithPreDownscaleIfNeeded(mozilla::image::DrawableFrameRef&&, gfxContext*, nsIntSize const&, mozilla::image::ImageRegion const&, GraphicsFilter, unsigned int) [RasterImage.cpp:f4123c7172ee : 2626 + 0x12]
23:20:00     INFO -      rbx = 0x0000000000000000   r12 = 0x0000000100523860
23:20:00     INFO -      r13 = 0x00007fff5fbfabd8   r14 = 0x0000000112487e00
23:20:00     INFO -      r15 = 0x00007fff5fbfad88   rip = 0x0000000101ec03cd
23:20:00     INFO -      rsp = 0x00007fff5fbfaa00   rbp = 0x00007fff5fbfaba0
23:20:00     INFO -      Found by: call frame info
23:20:00     INFO -   4  XUL!mozilla::image::RasterImage::Draw(gfxContext*, nsIntSize const&, mozilla::image::ImageRegion const&, unsigned int, GraphicsFilter, mozilla::Maybe<mozilla::SVGImageContext> const&, unsigned int) [RasterImage.cpp:f4123c7172ee : 2714 + 0x1e]
23:20:00     INFO -      rbx = 0x0000000100523860   r12 = 0x0000000000000018
23:20:00     INFO -      r13 = 0x0000000112487e00   r14 = 0x0000000000000001
23:20:00     INFO -      r15 = 0x0000000000000000   rip = 0x0000000101ec0659
23:20:00     INFO -      rsp = 0x00007fff5fbfabb0   rbp = 0x00007fff5fbfac20
23:20:00     INFO -      Found by: call frame info
Seth, I suspect this is yours?
Flags: needinfo?(seth)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #2)
> Seth, I suspect this is yours?

Indeed.
Depends on: 1069652
Clearing the needinfo for now since I believe this will be fixed in bug 1069652. If not, we'll reexamine the situation, but that bug covers the only obvious explanation I can see for this class of failure.
Flags: needinfo?(seth)
This seems to have gotten much rarer. I'm hoping that one of the many fixes I pushed in the past couple of weeks fixed it...

(This issue in particular I haven't been able to reproduce locally so far, unfortunately.)
Alright, I'm calling this fixed. We haven't hit it in a month.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.