Disable Flame OTA until bug 1068539 lands

RESOLVED FIXED

Status

Release Engineering
Releases
P1
blocker
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gerard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Bug 1068539 describes the issue: a js type change will make IndexedDB to explode on boot.
Our main switch is at the branch level, so I've disabled updates for all devices on mozilla-central/master. Normally I'd have AUS serve the last good nightly, but it's not clear what that is from reading bug 1068539, so I've disabled updates completely.
[Blocking Requested - why for this release]:
Blocks smoke tests and is a core function.

QAWanted to find the last good nightly we can point to that doesn't have bug 1068539.
blocking-b2g: --- → 2.2?
Keywords: qaurgent, qawanted, smoketest
(In reply to Peter Bylenga [:PBylenga] from comment #2)
> [Blocking Requested - why for this release]:
> Blocks smoke tests and is a core function.
> 
> QAWanted to find the last good nightly we can point to that doesn't have bug
> 1068539.

I don't think this is bug you want to request blocking for. We're just tracking disabling/re-enabling the updates here. Anything tracking the actual issue should probably go in bug 1068539.

In any case, if you you want to regression hunt the update server is not involved. You should look through the nightly directories on http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/. Eg: http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2014-09-16-16-02-04-mozilla-central-flame/.
The 20140917040204 nightly user build does not have bug 1068539.

Environmental Variables:
Device: Flame 2.2
BuildID: 20140917040204
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 8252eae8278c
Version: 35.0a1 (2.2) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
Flags: needinfo?(jmitchell)
Moving smoketest and nomination to root cause bug 1068539
blocking-b2g: 2.2? → ---
Keywords: smoketest
(Reporter)

Comment 6

3 years ago
Bug 1068539 is fixed.
Flags: needinfo?(pmoore)
Flags: needinfo?(bhearsum)
I re-enabled the nightly updates.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(pmoore)
Flags: needinfo?(bhearsum)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.