Add New Rule not translated in some non-english locales

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
4 years ago
3 months ago

People

(Reporter: adalucinet, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Reproducible on:
Firefox 33 beta 4 (BuildID: 20140915204924 ): 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
the latest Aurora (BuildID: 20140917004003 ):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
the latest Nightly (BuildID: 20140916133141):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0

Steps to reproduce:
1. Launch Firefox.
2. Open the Inspector -> Rules tab.
3. Open the context menu.

Expected results: 'Add rule' is translated.

Actual results: 'Add rule' is not translated.

Notes:
1. Gif showing this issue: http://goo.gl/cWBWPr
2. Only reproducible with some non-english builds (E.g.: ar, nb-NO)
3. Reproducible also with Firefox 33 beta 1 ar build - not a recent regression.
4. Reproducible on Windows 7 x64 and Ubuntu 12.04 x64.
Not reproduced on a french build (Add new rule is properly translated).
I move this to the "Translation" component, but if you're not seeing this anymore, feel free to close it.
Component: Developer Tools: Inspector → Translation
Flags: needinfo?(alexandra.lucinet)
Priority: -- → P3
(In reply to Nicolas Chevobbe [:nchevobbe] from comment #1)
> Not reproduced on a french build (Add new rule is properly translated).
> I move this to the "Translation" component, but if you're not seeing this
> anymore, feel free to close it.

Nicolas, the Translation component is for our built-in (experimental) "translate this page" functionality.
Component: Translation → Developer Tools: Inspector
If this isn't being translated, it's probably because translators haven't localised this yet.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alexandra.lucinet)
Resolution: --- → WORKSFORME
(In reply to Tim Nguyen :ntim from comment #2)
> (In reply to Nicolas Chevobbe [:nchevobbe] from comment #1)
> > Not reproduced on a french build (Add new rule is properly translated).
> > I move this to the "Translation" component, but if you're not seeing this
> > anymore, feel free to close it.
> 
> Nicolas, the Translation component is for our built-in (experimental)
> "translate this page" functionality.

Hi Tim, sorry about that. Generally speaking, should there be bugs for un-localised string ? And if so, which component should they be in ?
(In reply to Nicolas Chevobbe [:nchevobbe] from comment #4)
> (In reply to Tim Nguyen :ntim from comment #2)
> > (In reply to Nicolas Chevobbe [:nchevobbe] from comment #1)
> > > Not reproduced on a french build (Add new rule is properly translated).
> > > I move this to the "Translation" component, but if you're not seeing this
> > > anymore, feel free to close it.
> > 
> > Nicolas, the Translation component is for our built-in (experimental)
> > "translate this page" functionality.
> 
> Hi Tim, sorry about that. Generally speaking, should there be bugs for
> un-localised string ? And if so, which component should they be in ?

I think we file those bugs depending on the context the string is being used in. If it's used in devtools, it should be filed in devtools, etc.

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.