poster images for history view are sometimes not generated.

NEW
Assigned to

Status

()

P5
normal
5 years ago
2 years ago

People

(Reporter: jchaulk, Assigned: mfinkle)

Tracking

unspecified
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Roku Bug# TBD

poster images for history view are sometimes not generated.
tracking-fennec: ? → +
Video poster images are only used if the <video> element has a poster specified. We don't have a way to create a poster on the Roku device itself (that I know of), and creating one in Firefox then sending it over to the Roku seems a bit wasteful.

We should just fallback to a pretty "no poster" state.

Anthony and I can work on the pretty fallback.
Flags: needinfo?(alam)
Are these "posters" the thumbnails of videos? I.e. we just need a default thumbnail image for videos in the 'history' view?
(In reply to Anthony Lam (:antlam) from comment #2)
> Are these "posters" the thumbnails of videos? I.e. we just need a default
> thumbnail image for videos in the 'history' view?

Correct. Since we are using "two-row-flat-landscape-custom" for the Grid style, we need the following images sizes:
Image sizes: SD 138x77 HD 266x150 [1]

[1] http://sdkdocs.roku.com/display/sdkdoc/ifGridScreen
Created attachment 8495377 [details]
videothumn_default.zip

Give these a try, Mark.

I originally had the Firefox emblem in there but it seems to be a bit much when there's a string of them so I figure a 'play' button was fitting.
Flags: needinfo?(alam) → needinfo?(mark.finkle)
Assignee: nobody → mark.finkle
Flags: needinfo?(mark.finkle)
Priority: P2 → P5
You need to log in before you can comment on or make changes to this bug.