Mozilla doesn't tack .htm extension onto saved files

VERIFIED DUPLICATE of bug 31519

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 31519
16 years ago
a year ago

People

(Reporter: Matt Sheffield, Assigned: Matthew Paul Thomas)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.5) Gecko/20011011
BuildID:    20011101

If an extension is provided by the server other than .htm or .html, Mozilla by
default uses this extension, which results in the same problematic behavior.
(Ex: if saves remote filename "bob.php" but just types in "bob", it will become
"bob" and will not be treated as text/html by the user's OS.)

Default behavior on extension-based OSes should be to automatically tack .htm to
all locally saved files if user provides no extension. Potentially confusing to
novice users.

Reproducible: Always
Steps to Reproduce:
1. Save any file ending in non-.htm or .html you want

Expected Results:  Should tack on .htm or .html instead of leaving no extension

Comment 1

16 years ago
this feature should be only for content-type "text/html".
In unix, extensions are not essential.

reproduced in Mozilla 0.9.5/Linux.

Comment 2

16 years ago
.
Assignee: asa → mpt
Component: Browser-General → User Interface Design
QA Contact: doronr → zach
Whiteboard: DUPEME
(Reporter)

Comment 3

16 years ago
True, extensions don't matter on Unix, but they do on Windows, which presumably
we are trying to target here. All text/html documents should be saved as .htm
automatically.
Marking as dupe of bug 31519. Reporter: If you disagree, please reopen this bug.

-> File Handling, for parity with dupe

*** This bug has been marked as a duplicate of 31519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: User Interface Design → File Handling
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 5

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.