Closed Bug 1068699 Opened 5 years ago Closed 5 years ago

Each e-mail item should have a sensible reading order for the screen reader

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S5 (6feb)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: MarcoZ, Assigned: yzen)

References

Details

(Keywords: access, Whiteboard: [b2ga11y p=1])

Attachments

(1 file)

email option should have this order:

sender -> subject -> date -> body

Separated by commas so the speech pauses slightly between them and doesn't lump them together.
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Depends on: 1068705
Attached file Github pull request.
Attachment #8556588 - Flags: review?(jrburke)
Comment on attachment 8556588 [details] [review]
Github pull request.

Left some comments in the pull request, flip review back when ready. I can answer questions in the pull request on the review comments.

In general, if there is a way to reduce this work, maybe structure the HTML different to avoid the need to do this, I am open to considering those options.
Attachment #8556588 - Flags: review?(jrburke)
Comment on attachment 8556588 [details] [review]
Github pull request.

I think this should be in good shape now.
Attachment #8556588 - Flags: review?(jrburke)
Comment on attachment 8556588 [details] [review]
Github pull request.

This is looking great! Seems better than needing a bunch of l10n variant strings.

I observed fps and overpaint numbers, and I could not see a difference between master and this, so I think performance-wise this approach should be fine. I do see some checkerboarding, but see it in master too, and suspect just master instability/tuning as we have some other painting glitches currently (I filed a separate bug about that previously).

I just had one change around the sendState mentioned in the pull request. Once that is addressed, then this should be good to go.
Attachment #8556588 - Flags: review?(jrburke)
Comment on attachment 8556588 [details] [review]
Github pull request.

Took care of the comment, thanks!
Attachment #8556588 - Flags: review?(jrburke)
Attachment #8556588 - Flags: review?(jrburke) → review+
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27790

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
https://github.com/mozilla-b2g/gaia/commit/47cda5850572ed93088106e86a69fcd3d0c5c31f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8556588 [details] [review]
Github pull request.

[Approval Request Comment] This pull request fixes the order of email information in the list of emails.
[Bug caused by] (feature/regressing bug #): improvement, not a bug
[User impact] if declined: If declined, the order of information about an email within a list will remain confusing for the screen reader user.
[Testing completed]: manual, unit tests
[Risk to taking this patch] (and alternatives if risky): fairly low, some CSS changes that were tested manually.
[String changes made]: https://github.com/mozilla-b2g/gaia/pull/27790/files#diff-ae23daa44c8175428395919c6fa562b8
Attachment #8556588 - Flags: approval-gaia-v2.2?
Attachment #8556588 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
> +# LOCALIZATION NOTE(message-header-state-error): For message list card, used to
> +# describe an error state of the message item. The following string is spoken
> +# by screen readers and not shown on the screen.
> +message-header-state-error.ariaLabel=Error sending

This is about message that was not send or sending an error?
(In reply to Stefan Plewako [:stef] from comment #10)
> > +# LOCALIZATION NOTE(message-header-state-error): For message list card, used to
> > +# describe an error state of the message item. The following string is spoken
> > +# by screen readers and not shown on the screen.
> > +message-header-state-error.ariaLabel=Error sending
> 
> This is about message that was not send or sending an error?

AFAIK, this is when the message failed to send. Is that right, James?
Flags: needinfo?(jrburke)
Right, if the outbox folder is shown, and message in that outbox was waiting to be sent had an error on send, then this indicates the sending failed.
Flags: needinfo?(jrburke)
You need to log in before you can comment on or make changes to this bug.