The default bug view has changed. See this FAQ.

Adjust get_apk.sh with non existing armv6 build

RESOLVED FIXED

Status

Release Engineering
Release Automation
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: sylvestre, Assigned: sylvestre)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8490876 [details] [diff] [review]
armv6-not-available.diff

From version 31, we no longer generate armv6 builds.

./get_apk.sh 33.0b4
is failing because the apk is no longer available.

The attached patch manages that case.
It will display a warning when the apk is not available
and download it if available.
Attachment #8490876 - Flags: review?(hwine)
Comment on attachment 8490876 [details] [diff] [review]
armv6-not-available.diff

Review of attachment 8490876 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8490876 - Flags: review?(hwine) → review+
(Assignee)

Comment 2

3 years ago
Comment on attachment 8490876 [details] [diff] [review]
armv6-not-available.diff

Thanks. Merged:
https://hg.mozilla.org/build/braindump/rev/38666a55eec5
Attachment #8490876 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You could get the armv6 builds from dirs like
 http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/31.1.1esr-candidates/build1/android-armv6/en-US/

I'm not sure how you figure out what the right version is to match the mainline 32.0.x. Also note that I've used the en-US dir, from IRC discussion with kbrosnan in #r-d last week where he said we use en-US because it is much easier on low-spec devices.
(Assignee)

Updated

2 years ago
Assignee: nobody → sledru
You need to log in before you can comment on or make changes to this bug.