FF32 on HP Slate 21 - X.innerHTML = 'y' does not trigger a repaint of X, pan/zoom repaints once

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
2 months ago

People

(Reporter: semihbattal1957, Unassigned)

Tracking

32 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

Steps to reproduce:

Tried to display the following page:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>FF32 innerHTML Repaint Test</title>
    <script type="text/javascript">
        {
            function myTimer() {
                var d = new Date();
                var X = document.getElementById("tmrDsp");
                X.innerHTML = d.toLocaleTimeString();
            }

            var myClock = setInterval(function () { myTimer() }, 1000);
        }
    </script>
</head>
<body>
    <p id="tmrDsp" style="font-size: x-large; text-align: center">
        &nbsp;
    </p>
</body>
</html>



Actual results:

Nothing, no display


Expected results:

Current time should have been displayed and updated one a second.
( Zooming/unzooming displays it, but only once per zoom/unzoom. )
(Reporter)

Updated

4 years ago
OS: Windows XP → Android
Hardware: x86 → HP
Hardware: HP → ARM

Comment 1

2 months ago
Hello Semihbattal1957,

I couldn't reproduce this issue following the steps from the description on the latest Nightly with a Samsung Galaxy S8+ Android 8.0.0.
Note that the current time was displayed and updated every second.
I will close this issue as worksforme, if this issue is still reproducible to you, please re-open it and mention what devices and android you used.

Thanks,
Andrei
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

2 months ago
(In reply to AndreI Bodea from comment #1)
> Hello Semihbattal1957,
> 
> I couldn't reproduce this issue following the steps from the description on
> the latest Nightly with a Samsung Galaxy S8+ Android 8.0.0.
> Note that the current time was displayed and updated every second.
> I will close this issue as worksforme, if this issue is still reproducible
> to you, please re-open it and mention what devices and android you used.
> 
> Thanks,
> Andrei

Hello Andrei,

Thank you for your comment.
But, this bug disappeared a long time ago...

Thanks,
Semih BATTAL
You need to log in before you can comment on or make changes to this bug.