[Camera] Recording timer is permanently screen reader visible

RESOLVED FIXED in Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: eeejay, Assigned: bugzilla)

Tracking

({access})

unspecified
2.2 S8 (20mar)
All
Gonk (Firefox OS)
access
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
#view14.recording-timer seems to be hidden with opacity alone. That isn't good enough.

Updated

4 years ago
Component: Gaia → Gaia::Camera
Summary: Recording timer is permanently screen reader visible. → [Camera] Recording timer is permanently screen reader visible
(Assignee)

Updated

4 years ago
Assignee: nobody → bugzilla
Created attachment 8573360 [details] [review]
[gaia] FunkTron:Bug1068887 > mozilla-b2g:master
(Assignee)

Comment 2

4 years ago
Hey Yura,

The PR addresses both the Recording Timer listed in the Bug description as well as a few other things I noticed along the way...

- Added L10n ID + role to 'thumbnail button'
- Added role to 'camera button' on mode switch
- Added role to 'video button' on mode switch
- Added L10n ID + role to 'capture button'
- Added logic to modify the L10n ID of the capture button as different modes are activated

I've unfortunately run into an issue here where MozL10n doesn't appear to be initialized in time to update the views as they're injected, so the ARIA-Labels remain unchanged at App Launch.  I wrestled with it for a little while until I realized that MozL10n is handled a little differently in the Camera app (possibly related to Bug 999132) and figured I should inquire first.  Any suggestions for how best to proceed?
Flags: needinfo?(yzenevich)
(Assignee)

Comment 3

4 years ago
UPDATE:

Figured out the localization issue after looking through some other examples.  Cleaned up the logic a bit and added tests.  Let me know what you think!
(In reply to Ross from comment #2)
> Hey Yura,
> 
> The PR addresses both the Recording Timer listed in the Bug description as
> well as a few other things I noticed along the way...
> 
> - Added L10n ID + role to 'thumbnail button'
> - Added role to 'camera button' on mode switch
> - Added role to 'video button' on mode switch
> - Added L10n ID + role to 'capture button'
> - Added logic to modify the L10n ID of the capture button as different modes
> are activated
> 
> I've unfortunately run into an issue here where MozL10n doesn't appear to be
> initialized in time to update the views as they're injected, so the
> ARIA-Labels remain unchanged at App Launch.  I wrestled with it for a little
> while until I realized that MozL10n is handled a little differently in the
> Camera app (possibly related to Bug 999132) and figured I should inquire
> first.  Any suggestions for how best to proceed?

Hi Ross, overall looks really good. I appreciate that you took care of the labels/roles of other controls as well, but I believe we have other contributor working on that stuff at the moment (it's in another bug). Same goes for the thumbnails, I'm currently wrapping that stuff up. I guess it helps a great deal when testing (since the controls are inaccessible), but would you be able to submit your pull request for the timer stuff only? Thanks and sorry for the extra work!
Flags: needinfo?(yzenevich)
(Assignee)

Comment 5

4 years ago
Hey Yura,

No probs.  Updated the PR to only include Recording Timer stuff.
Flags: needinfo?(yzenevich)
(In reply to Ross from comment #5)
> Hey Yura,
> 
> No probs.  Updated the PR to only include Recording Timer stuff.

Looks good, Ross, some comments and then mark me for a11y-review.
Flags: needinfo?(yzenevich)
(Assignee)

Updated

4 years ago
Attachment #8573360 - Flags: a11y-review?(yzenevich)
Comment on attachment 8573360 [details] [review]
[gaia] FunkTron:Bug1068887 > mozilla-b2g:master

Looks good from the a11y side. Marking
Attachment #8573360 - Flags: review?(jdarcangelo)
Attachment #8573360 - Flags: a11y-review?(yzenevich)
Attachment #8573360 - Flags: a11y-review+
Comment on attachment 8573360 [details] [review]
[gaia] FunkTron:Bug1068887 > mozilla-b2g:master

Hi Ross, I was playing around with the recording mode, there's a visibility issue when we are recording (of some of the controls) that we might want to take care of in this bug. Removing the flags for the time being.
Attachment #8573360 - Flags: review?(jdarcangelo)
Attachment #8573360 - Flags: a11y-review+
(Assignee)

Comment 9

4 years ago
Okay, do you know which controls?  Let me know what you'd like me to adjust and I'll take a look!
Flags: needinfo?(yzenevich)
(In reply to Ross from comment #9)
> Okay, do you know which controls?  Let me know what you'd like me to adjust
> and I'll take a look!

Yeah, basically you can notice when you press on the record button, preview and audio/video toggle are hidden (i suspend indicators view might as well) but with opacity only.
Flags: needinfo?(yzenevich)
(Assignee)

Comment 11

4 years ago
So, here's what's up:

Indicators => Appropriately hidden with "display:none" already
Preview => Taken care of in PR
Mode Switch => Taken care of in PR
(Assignee)

Updated

4 years ago
Attachment #8573360 - Flags: a11y-review?(yzenevich)
Comment on attachment 8573360 [details] [review]
[gaia] FunkTron:Bug1068887 > mozilla-b2g:master

Works great! Could you just add one more thing to make it awesome: add role="timer" to the recording-timer view (its el) so we get timer update if we are focused on it. Once you're done, mark jdarcangelo for the review. Thanks!
Attachment #8573360 - Flags: a11y-review?(yzenevich) → a11y-review+
(Assignee)

Updated

4 years ago
Attachment #8573360 - Flags: review?(jdarcangelo)
(Assignee)

Comment 13

4 years ago
Cool, added the 'timer' role.  Should be all set!
Comment on attachment 8573360 [details] [review]
[gaia] FunkTron:Bug1068887 > mozilla-b2g:master

Looks good. Thanks for the patch!
Attachment #8573360 - Flags: review?(jdarcangelo) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8573360 [details] [review]
[gaia] FunkTron:Bug1068887 > mozilla-b2g:master

[Approval Request Comment] This PR fixes visibility around video mode in Camera app.
[Bug caused by] (feature/regressing bug #): improvement, not a bug
[User impact] if declined: if declined accessibility around video capture will not be optimal.
[Testing completed]: unit + on device
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8573360 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8573360 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/ad4ecd2bd58fe37a8d55a8a66c9d19a887518b78
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S8 (20mar)
You need to log in before you can comment on or make changes to this bug.