Closed Bug 1068909 Opened 7 years ago Closed 7 years ago

[Camera] Improve accessibility of the preview screen.

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S8 (20mar)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: eeejay, Assigned: yzen)

References

Details

(Keywords: access, late-l10n, Whiteboard: [b2ga11y p=1])

Attachments

(1 file)

I could still navigate to the controls on the camera viewfinder screen when previewing an image with the screen reader.
Summary: Preview screen does not have exclusive visiblity → [Camera] Preview screen does not have exclusive visiblity
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
The following things need to be addressed:
* Visibility issues around various menus
* Labels for controls
* Swipe navigation across frames.
Summary: [Camera] Preview screen does not have exclusive visiblity → [Camera] Improve accessibility of the preview screen.
Attachment #8575359 - Flags: review?(jdarcangelo)
Comment on attachment 8575359 [details] [review]
[gaia] yzen:bug-1068909 > mozilla-b2g:master

See comments in PR. We should re-use the `swipe` event instead of introducing `wheel:left` and `wheel:right` events.
Attachment #8575359 - Flags: review?(jdarcangelo) → review-
Comment on attachment 8575359 [details] [review]
[gaia] yzen:bug-1068909 > mozilla-b2g:master

Addressed comments, thanks!
Attachment #8575359 - Flags: review- → review?(jdarcangelo)
Comment on attachment 8575359 [details] [review]
[gaia] yzen:bug-1068909 > mozilla-b2g:master

Looks good. Just a minor nit in the PR comments about using `emit()` instead of `fire()` for consistency. They both reference the exact same method though so its not super important.
Attachment #8575359 - Flags: review?(jdarcangelo) → review+
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8575359 [details] [review]
[gaia] yzen:bug-1068909 > mozilla-b2g:master

[Approval Request Comment] This PR improves accessibility for thumbnail preview of the Camera app.
[Bug caused by] (feature/regressing bug #): improvement not a bug.
[User impact] if declined: If declined the screen reader users will not be able to use the preview section of the Camera app
[Testing completed]: unit tests + on device
[Risk to taking this patch] (and alternatives if risky): mainly a11y related attribute and css fixes.
[String changes made]: https://github.com/mozilla-b2g/gaia/pull/28751/files#diff-e4bc27afcad6f10d1abaf8eced7aa340
Attachment #8575359 - Flags: approval-gaia-v2.2?
Attachment #8575359 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.