operator shelves don't show up when falling back to RoW

VERIFIED FIXED in 2014-09-23

Status

--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: kngo)

Tracking

2014-09-23
x86
Gonk (Firefox OS)
Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
steps to reproduce:
1. Notice the two published operator shelves
- https://marketplace-dev.allizom.org/curate/manage/shelves/this-is-an-op-shelf
- https://marketplace-dev.allizom.org/curate/manage/shelves/test-app
2. Go to the homepage with that region and carrier combo


expected behavior:
operator shelves show up

actual behavior:
Operator shelves are missing even after publishing them
https://marketplace-dev-cdn.allizom.org/api/v2/feed/get/?cache=1&carrier=megafon&lang=en-US&limit=10&region=ec&vary=0
(Reporter)

Updated

4 years ago
Summary: Operator shelves are not showing up → Newly-created Operator shelves are not showing up
(Assignee)

Comment 1

4 years ago
This is because there weren't any Feed Items specifically published for Ecuador. So when you visited Ecuador, it did a fallback to the Rest of World feed. The feed falls back to Rest of World when there is either an empty feed or a feed consisting of only a shelf. The problem is that when the feed falls back, we can lose the shelf in the process.

When we fall back, we need to keep the shelf and prepend it to the Rest of World feed.
Assignee: nobody → kngo
(Assignee)

Comment 2

4 years ago
https://github.com/mozilla/zamboni/pull/2568
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Summary: Newly-created Operator shelves are not showing up → operator shelves don't show up when falling back to RoW
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2014-09-23

Comment 3

4 years ago
Verified as fixed : http://screencast.com/t/d2o0lTrxapo
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.