[Task Manager] Card View screen orientation behavior is dependant on the most recent app.

VERIFIED DUPLICATE of bug 1118390

Status

VERIFIED DUPLICATE of bug 1118390
4 years ago
4 years ago

People

(Reporter: Marty, Assigned: etienne)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8491033 [details]
logcat-Task Manager.txt

Description:
If the user enters the Task manager from a Portrait locked app (or the Homescreen), the Task Manager will be portrait locked.  If the user enters from a Landscape locked app (such as Cut the Rope), the Task Manager will be landscape locked.  If the user enters from an app that supports both screen orientations, the user will be able to rotate the device and switch screen orientations from within the Task Manager.

This is inconsistent behavior, and may confuse the user as to why they sometimes can or cannot use the Task Manager with specific screen orientations.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140916040203
2) Launch the Settings app, then enter the Task Manager, attempting to rotate screen orientation.
3) Download 'Cut the Rope' from the Marketplace
4) Launch 'Cut the Rope'', then enter the Task Manager, attempting to rotate screen orientation.
5) Launch the Browser app, then enter the Task Manager, attempting to rotate screen orientation.
  
Actual:
Task Manager screen orientation behavior is inconsistent, depending on the most recent app used.
  
Expected: 
Task Manager screen orientation behavior is consistent across all apps used.
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140916040203
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 3b7921328fc1
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Note: This issue occurs with both 319MB and 512MB memory
  
Repro frequency: 5/5
See attached: logcat

--------------------------------------------------------------------------------

Issue does NOT occur in Flame 2.1.
Task Manager does not support Landscape screen orientation in 2.1

Environmental Variables:
Device: Flame 2.1
BuildID: 20140917000205
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: e20869e87e23
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [systemsfe]
needinfo on the qa lead for System: Window Management for blocking nomination triage.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
I ran into this also while trying to figure out bug 1054949. In the old carousel-style cards view it was always portrait orientation locked so this was not an issue (kinda)
Blocks: 1054949
I'll take this as I need it for 1054949, but I dont know yet what it will take to fix, so if you do, please feel free to steal it!
Target Milestone: --- → 2.1 S5 (26sep)

Comment 4

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Flags: needinfo?(gchang)
Why are we requesting blocking 2.1 here? The bug poster says "Issue does NOT occur in Flame 2.1." and "Task Manager does not support Landscape screen orientation in 2.1" ? 

Agreed this should block 2.2 as it was introduced by bug 1061324 where we introduced the possibility of landscape-orientation card view.

Updated

4 years ago
blocking-b2g: 2.1? → 2.2?
blocking-b2g: 2.2? → 2.2+
Target Milestone: 2.1 S5 (26sep) → ---
(Assignee)

Updated

4 years ago
Assignee: nobody → etienne
(Assignee)

Comment 6

4 years ago
Created attachment 8501150 [details] [review]
Gaia PR
Attachment #8501150 - Flags: review?(sfoster)
Comment on attachment 8501150 [details] [review]
Gaia PR

The patch looks good as it stands, but it really highlights bug 1054949 - we now see screenshots getting squished to fit different aspect ratios. I'm not sure if we can land one without the other - its very distracting and makes it confusing to verify this bug. 
It would be nice to show the card strip in the correct orientation initially, rather than rotating it after its shown. I'm cancelling review so we can discuss - though it might make end up making sense to land as-is and follow up.
Attachment #8501150 - Flags: review?(sfoster)
(Assignee)

Comment 8

4 years ago
Makes perfect sense to do bug 1054949 first since
* this patch probably won't bitrot too much
* we can work on bug 1054949 from master, just need to launch the cardview from a browser sheet

Marking it as such.
No longer blocks: 1054949
Depends on: 1054949

Comment 9

4 years ago
Consistency is key to perceived quality. Please fix
blocking-b2g: 2.2+ → 2.1?
Whiteboard: [systemsfe] → [systemsfe] [Tako_Blocker]
(Assignee)

Comment 10

4 years ago
This should not be reproducible on 2.1 since the 2.1 card view only support portrait.

Updated

4 years ago
Whiteboard: [systemsfe] [Tako_Blocker] → [systemsfe]

Updated

4 years ago
blocking-b2g: 2.1? → ---

Updated

4 years ago
Duplicate of this bug: 820673

Updated

4 years ago
Duplicate of this bug: 1104599

Updated

4 years ago
Blocks: 1111795
We're locking orientation in bug 1118390 which directly addresses this bug
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118390
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.