If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Photo view: Adjacent photos should be hidden from screen reader

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

(Blocks: 1 bug, {access})

unspecified
2.2 S4 (23jan)
All
Gonk (Firefox OS)
access

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
They are currently scrolled into view by navigating. This messes up the state of the photo viewer.
(Assignee)

Updated

3 years ago
Assignee: nobody → eitan
(Assignee)

Comment 1

3 years ago
Created attachment 8544159 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27127
(Assignee)

Comment 2

3 years ago
Comment on attachment 8544159 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27127

This is a pretty simple patch. I added zac as a reviewer for the ui testing bits.
Attachment #8544159 - Flags: review?(zach)
Attachment #8544159 - Flags: review?(pdahiya)
Comment on attachment 8544159 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27127

r+ for the changes other than python tests. I am not familiar with python tests and will have Zac review testing part of the patch. Thanks!
Attachment #8544159 - Flags: review?(pdahiya) → review+
(Assignee)

Comment 4

3 years ago
Comment on attachment 8544159 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27127

Bebe,

Could you please review the test?
Attachment #8544159 - Flags: review?(zach) → review?(florin.strugariu)
Comment on attachment 8544159 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27127

Pull looks OK to me...

I still have a question about the `debug` tag

retriggered the build a few times to check for intermittent fails
(Assignee)

Comment 6

3 years ago
Looks green now.

I copied the skip condition from here, because it is a very similar test:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/manifest.ini#L19
Attachment #8544159 - Flags: review?(florin.strugariu) → review+
https://github.com/mozilla-b2g/gaia/commit/e91cdb71d55e29bf41cca768591db64785d63801
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8544159 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27127

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Adjacent frames of photos/videos will be "visible" to the screen reader user.
[Testing completed]: Manual and Gip test added.
[Risk to taking this patch] (and alternatives if risky): Low, changes are to aria-hidden which has no affect on layout.
[String changes made]: None.
Attachment #8544159 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8544159 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/c2cb70fad2295dff01eeb0cbd648d4f279d76d6d
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S4 (23jan)
You need to log in before you can comment on or make changes to this bug.