Video view: Play and pause buttons are not labeled

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

({access})

unspecified
2.2 S5 (6feb)
All
Gonk (Firefox OS)
access
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
The play button in the center of the screen, and the pause button in the lower left are not labeled.
(Assignee)

Comment 1

4 years ago
Created attachment 8555623 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27722
Attachment #8555623 - Flags: review?(dflanagan)
(Assignee)

Updated

4 years ago
Assignee: nobody → eitan
(Assignee)

Updated

4 years ago
Blocks: 1068976

Updated

4 years ago
Blocks: 1068912, 1068915
Comment on attachment 8555623 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27722

r+ if you fix the indentation nits and add the missing .ariaLabel to the fullscreen button label.  Also consider renaming the shared properties file to something more specific than "media".  media/controls.en.properties sounds good to me.
Attachment #8555623 - Flags: review?(dflanagan) → review+
(Assignee)

Comment 3

4 years ago
(In reply to David Flanagan [:djf] from comment #2)
> Comment on attachment 8555623 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27722
> 
> r+ if you fix the indentation nits and add the missing .ariaLabel to the
> fullscreen button label.  Also consider renaming the shared properties file
> to something more specific than "media".  media/controls.en.properties
> sounds good to me.

I want to have a place for other strings that are not playback controls, but still media related, like the frame descriptions in bug 1068976. Waiting for your feedback there before merging this.
(Assignee)

Comment 4

4 years ago
https://github.com/mozilla-b2g/gaia/commit/0693417c57ca55f48806b6bae3647ed7516f055a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
Comment on attachment 8555623 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27722

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Play and pause buttons won't be accessible to screen reader users
[Testing completed]: Yes. This has also been on master for a while.
[Risk to taking this patch] (and alternatives if risky): Little
[String changes made]: Yes, new strings for video control buttons (copied from system app).
Attachment #8555623 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8555623 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/584273c435704f54e17568a5864e2d384af0c429
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S5 (6feb)
This bug has been verified as "pass" on latest Nightly build of Flame v2.2&3.0.

STR:
1.Enable Screen Reader in Settings.
2.Go to Gallery app and select a video.
3.Simulate the blind to tap these video control buttons.
**Both the "Play" and "Pause" button are labeled by the voice "play button"/"pause button" ("play button gallery"/"pause button gallery").


See attachment: verified_v2.2&3.0.3gp
Reproduce rate: 0/10


Device: Flame v2.2 build(Verified)
Build ID               20150619002501
Gaia Revision          1c33072e33c279c8aa5cb5e4a3e4da6af6cd818b
Gaia Date              2015-06-19 01:36:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5ad34a170633
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150619.042950
Firmware Date          Fri Jun 19 04:30:02 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v3.0 build(Verified)
Build ID               20150622160206
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150622.193834
Firmware Date          Mon Jun 22 19:38:45 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Created attachment 8625437 [details]
verified_v2.2&3.0.3gp
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.