Video view: Video seek bar is not accessible.

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

(Blocks: 1 bug, {access})

unspecified
2.2 S6 (20feb)
All
Gonk (Firefox OS)
access

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

3 years ago
The collection of distinct accessible nodes should be made into one comprehensive accessible widget.
(Assignee)

Comment 1

3 years ago
Created attachment 8556785 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27799

I chose this approach because (at least in the gallery view) one of the dialogs is translucent. Otherwise, doing this in CSS would be preferable (and potentially cleaner).
Assignee: nobody → eitan
Attachment #8556785 - Flags: review?(pdahiya)
(Assignee)

Comment 2

3 years ago
Comment on attachment 8556785 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27799

Wrong bug, pleased ignore!
Attachment #8556785 - Attachment is obsolete: true
Attachment #8556785 - Flags: review?(pdahiya)
(Assignee)

Updated

3 years ago
Assignee: eitan → nobody
Created attachment 8559347 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27932
(Assignee)

Comment 4

3 years ago
Created attachment 8559349 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27932
Attachment #8559349 - Flags: review?(dflanagan)
(Assignee)

Comment 5

3 years ago
Comment on attachment 8559347 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27932

Need to get used to this autolander business..
Attachment #8559347 - Attachment description: [PullReq] eeejay:bug-1068999 to mozilla-b2g:master → Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27932
Attachment #8559347 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Assignee: nobody → eitan
Comment on attachment 8559349 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27932

r+ if you fix the nits noted on github.

Does the screen reader currently send the keyboard events? I seem to recall Punam saying last week that it wasn't working yet. If it is not working, I'd recommend waiting to land this until it can actually be tested.
Attachment #8559349 - Flags: review?(dflanagan) → review+
(Assignee)

Comment 7

3 years ago
https://github.com/mozilla-b2g/gaia/commit/74af2e3c426e753aaa269d0c22232a4f2959c940

Tested locally, and a fix for screen reader breakage is landing in gecko as we speak.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8559349 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27932

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Screen reader users will not be able to perceive or operate the video player seek bar.
[Testing completed]: Yes. This has been on master for a while.
[Risk to taking this patch] (and alternatives if risky): Little/no risk
[String changes made]: Added screen reader label description for seek bar.
Attachment #8559349 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8559349 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/f62f62fd54cb79df6b4e9f1253e09db6ebe2082c
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S6 (20feb)
Linter follow-up fix. I have no clue why Master isn't complaining about this, though :(
v2.2: https://github.com/mozilla-b2g/gaia/commit/be86a57c64529b651e67ba4ae87d70acffbc986a

https://treeherder.mozilla.org/logviewer.html#?job_id=45638&repo=mozilla-b2g37_v2_2
Flags: needinfo?(kgrandon)
It looks like we're running jshint 2.6 in master, and 2.5.x in v2.2 currently. It seems that JShint may have relaxed this rule and that's why we're not seeing it on master.

That could certainly complicate uplifts =/ If it's trivial to get jshint 2.6 onto v2.2 we should do so to ease the pain.
Flags: needinfo?(kgrandon)
FYI - I'll track getting jshint updated in 2.2 in bug 1132819.
You need to log in before you can comment on or make changes to this bug.