Closed Bug 1069034 Opened 5 years ago Closed 5 years ago

Update Valgrind suppressions to handle the more detailed stack traces given by Valgrind 3.10

Categories

(Testing :: General, defect)

defect
Not set

Tracking

(firefox33 wontfix, firefox34 fixed, firefox35 fixed)

RESOLVED FIXED
mozilla35
Tracking Status
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: njn, Assigned: njn)

References

Details

Attachments

(1 file)

Valgrind 3.10 is able to get inlined frames in its stack traces, which has
broken some of our suppressions.
With 3.10, I am seeing an extra |operator new| frame beneath the |moz_xmalloc|
frame. Using a |...| wildcard will make the suppression work with both 3.10 and
earlier versions.
Attachment #8491155 - Flags: review?(jseward)
Attachment #8491155 - Flags: review?(jseward) → review+
https://hg.mozilla.org/mozilla-central/rev/0e9883d2467b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Duplicate of this bug: 1081115
You need to log in before you can comment on or make changes to this bug.