Closed Bug 1069064 Opened 5 years ago Closed 5 years ago

[System] Browser bookmarks not migrated to homescreen icons on OTA from 2.0 to 2.1

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: ychung, Assigned: qdot)

References

Details

(Keywords: dataloss, regression, Whiteboard: [2.1-flame-test-run-2][systemsfe])

Attachments

(3 files)

Description:
When user has existing browser bookmarks on 2.0 then performs an OTA update to 2.1, the bookmarks are not properly migrated to homescreen icons after update. Only the last added bookmark from 2.0 is migrated to 2.1 homescreen.
   
Repro Steps:
1) Update a Flame device to 2.0 BuildID: 20140917000200
2) Change update channel and url on device to appropriate 2.1 build (20140917000205)
3) Create new bookmarks on Browser app.
4) Perform OTA update.
  
Actual:
Existing browser bookmarks are not properly migrated to homescreen icons after 2.0 to 2.1 OTA. Only the last added bookmark from 2.0 is migrated to 2.1 homescreen.
  
Expected: 
All browser bookmarks become homescreen icons after 2.0 to 2.1 OTA.

[Before OTA - Flame 2.0]
Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140917000200
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0) 
Firmware Version: L1TC00011230
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

[After OTA - Flame 2.1]
Enviromental Variables:
Device: Flame 2.1 (319mb)
BuildID: 20140917000205
Gaia: 47939f4c41d0c941e5047e5d1af74a79b7d8e0d5
Gecko: e20869e87e23
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro Frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/14616/
See attached: logcat, screenshot
leaving qawanted for branch check
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Attached image Bookmarks_OTA.png
Assignee: nobody → kyle
It really helps if we actually call the right function to continue migrating bookmarks when we start doing it. :|
Attachment #8491216 - Flags: review?(dale)
[Blocking Requested - why for this release]: Will only migrate one bookmark. Possible dataloss if browser removal was to land before this.
blocking-b2g: --- → 2.1?
Whiteboard: [2.1-flame-test-run-2] → [2.1-flame-test-run-2][systemsfe]
Target Milestone: --- → 2.1 S5 (26sep)
Comment on attachment 8491216 [details] [review]
Patch 1 (v1) - Make sure we call correct continuation function when migrating bookmarks

Looks good
Attachment #8491216 - Flags: review?(dale) → review+
data migration
blocking-b2g: 2.1? → 2.1+
Issue still reproduces, this bug has been re-written as bug 1069064
Disregard Comment 7
https://github.com/mozilla-b2g/gaia/commit/86cc547faf0fe0c0ffab1444e01cd5c7f2425ee6
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8491216 [details] [review]
Patch 1 (v1) - Make sure we call correct continuation function when migrating bookmarks

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1055593
[User impact] if declined: Data loss, only 1 bookmark will migrate
[Testing completed]: Testing on device
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8491216 - Flags: approval-gaia-v2.1?
Keywords: qawantedregression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8491216 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
The bookmarks are now migrated properly after OTA upgrade 2.0 to 2.1; 2.0 to 2.2; 2.1 to 2.2:

BEFORE - Flame 2.0

Environmental Variables:
Device: Flame 2.0
BuildID: 20140923000205
Gaia: 8d7f2ac85f3154bdb149d67e5c2f9b035f5e4105
Gecko: 6dd19beda1c2
Version: 32.0 (2.0) 
Firmware Version: L1TC00011230
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

AFTER - Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)
BuildID: 20140923000204
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------------
BEFORE - Flame 2.0

Environmental Variables:
Device: Flame 2.0
BuildID: 20140923000205
Gaia: 8d7f2ac85f3154bdb149d67e5c2f9b035f5e4105
Gecko: 6dd19beda1c2
Version: 32.0 (2.0) 
Firmware Version: L1TC00011230
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

After - Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140923040203
Gaia: 3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko: 790f41c631cc
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------------
BEFORE - Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)
BuildID: 20140923000204
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

After - Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140923040203
Gaia: 3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko: 790f41c631cc
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
in-testsuite- for bugs which can not yet be tested with a marionette test.
Blocks: 1083253
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.