Character not displayed after closing tag for nested inline element

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Antti Näyhä, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:2001121093])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Overview description:
  In certain situations, a character after a nested inline element closing tag
  is not displayed.

Steps to reproduce:
  View the attachment "Test case".

Actual results:
  The text "foo", without a full stop character after it.
Expected results:
  The text "foo."

Build Date & Platform:
  0.9.5 (Linux)

Additional Builds and Platforms:
  0.9.2 (Windows)

Additional Information:
  - it doesn't seem to matter which inline elements are used in place of <em>
    and <strong> in the test case
  - the bug remains if the full stop is replaced by eg. a square bracket
  - the bug disappears if the full stop is replaced by eg. a letter
  - the bug disappears if there are two or more characters after </em>
  - the bug disappears if the space before </strong> is removed

In short, one of the weirded ones...
(Reporter)

Comment 1

16 years ago
Created attachment 55224 [details]
Test case
(Reporter)

Comment 2

16 years ago
It's still there on build 2001-10-25-21 (Linux).
Keywords: testcase

Comment 3

16 years ago
Content model:
  body@02904E10 refcount=3<
    table@02925120 refcount=6<
      Text@02925080 refcount=2<\n>
      tbody@02926F80 refcount=3<
        tr@02926E90 refcount=3<
          Text@02926DD0 refcount=2<\n>
          td@02926CB0 align=Center refcount=4<
            Text@02926B00 refcount=3<\n>
            strong@029269E0 refcount=3<
              em@029268F0 refcount=3<
                Text@02926890 refcount=3<foo>
              >
              Text@02926800 refcount=3<. > <<<<<< NOTICE the period <<<<<<
            >
            Text@02926670 refcount=3<\n>
          >
          Text@02926E30 refcount=2<\n>
        >
        Text@029264D0 refcount=2<\n>
      >
    >
    Text@02926300 refcount=3<\n>
  >
>

--> layout
Assignee: harishd → attinasi
Component: Parser → Layout
QA Contact: moied → petersen

Comment 4

16 years ago
this seems to only happen in a table, I removed the table and it renders 
correctly, I wrapped it within a div and it renders correctly. I am going to 
hand this over to karnaze for a look to see if this has something to do with the 
table code
Assignee: attinasi → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → amar
Whiteboard: [bae:2001121093]
(Assignee)

Comment 5

16 years ago
Temporarily moving to future until a milestone can be assigned. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 6

16 years ago
this is working for me, WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
Works for me on Linux/20020115 as well.  Still gotta test on Windows and Mac...
(Reporter)

Comment 8

16 years ago
Works on Windows/2002011503, too.

Could somebody try it on a recent Mac nightly and verify as Worksforme?  Thanks.
(Reporter)

Comment 9

16 years ago
OK, verified fixed on 0.9.8/MacOSX.  Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.