.PDF file association incorrectly created when AcroReader is already installed

RESOLVED DUPLICATE of bug 1049521

Status

()

RESOLVED DUPLICATE of bug 1049521
4 years ago
4 years ago

People

(Reporter: bugzy2005, Unassigned)

Tracking

32 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140911151253

Steps to reproduce:

* Installed AcroReader v11.0 onto Win 7 64-bit platform using admin-enabled account.
* Run the Firefox installer from an admin-enabled account, but did NOT launch Firefox at the end of the installation.
* Run Firefox from a non-admin account
* Firefox configured in Options to "Always ask" when opening PDF files.
* Browse to a site and download a PDF document
* At the pop-up dialog, either (a) select "Open" ... in Firefox or (b) "Save to disk" and then double-click on the saved file


Actual results:

The PDF document never opens ... the pop-up dialog keeps getting re-displayed and prgress can never be made to get past it. Even double-clicking the PDF file from an Explorer window results in the endless chain of dialogs being entered.




Expected results:

The problem appears to be due to the creation of the following entry in the user's registry settings:

REGEDIT4
[HKEY_USERS\S-1-5-21-<SID>-1001_Classes\.pdf]
@="FirefoxHTML"

which wrecks the .PDF file association that was created when AdobeReader was installed. Deleting this key from the registry allows the system-wide default association (under KLM\Classes) to no longer be obscured, allow PDFs to be opened in the usual manner.

The Firefox installer reinstalls this registry corruption whenever it runs, either when installing Firefox for the "first" time, or when running the installer to update an older version of Firefox. I think this behaviour started with either the v30 or v31 version of Firefox.

The problem appears to be due to an incorrect implementation for the fix for bug  452254 (https://bugzilla.mozilla.org/show_bug.cgi?id=452254). The registration details of the AcroReader v11 installation are cached at this location in the registry: 
HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{AC76BA86-7AD7-1033-7B44-AB0000000001}. It seems to me that the FF installer isn't checking for this, deeming that no PDF handling application is installed and then corrupting the registry in an attempt to have FF open .PDF files.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049521
You need to log in before you can comment on or make changes to this bug.