Closed Bug 10692 Opened 20 years ago Closed 20 years ago

GetFolder: unixlocal and unixlib crash when triggered

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3, critical)

Other
Linux
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: jimmykenlee, Assigned: dougt)

Details

(Keywords: crash, platform-parity)

Build: 7/28/99 SeaMonkey build

1. From http://jimbob/trigger2.html, trigger
   http://jimbob/jars/a_getfolder_1_unixlocal.jar and
   http://jimbob/jars/a_getfolder_2_unixlib.jar

//a_getfolder_1_unixlocal.jar
Install.StartInstall("Acceptance: a_getfolder_1_unixlocal", regName, vi, 0);
f = Install.GetFolder("Unix Local");
Install.AddSubcomponent(regName, jarSrc, f, jarSrc);

//a_getfolder_2_unixlib
Install.StartInstall("Acceptance: a_getfolder_2_unixlib", regName, vi, 0);
f = Install.GetFolder("Unix Lib", "getfolder_unixlib");
Install.AddSubcomponent(regName, jarSrc, f, jarSrc);

RESULT:
The Install.log shows the following:
---------------------------------------------------------------------------
http://jimbob/jars/a_getfolder_1_unixlocal.jar     --     07/28/1999 11:36:18
---------------------------------------------------------------------------
Acceptance: a_getfolder_1_unixlocal

** ERROR (-3): Replacing /usr/local/netscape/smrtupdt.txt
Install script aborted

Finished Installation  07/28/1999 11:36:18

---------------------------------------------------------------------------
http://jimbob/jars/a_getfolder_2_unixlib.jar     --     07/28/1999 11:36:42
---------------------------------------------------------------------------
Acceptance: a_getfolder_2_unixlib

** ERROR (-3): Installing:/usr/local/lib/netscape/getfolder_unixlib/smrtupdt.txt

Install script aborted
Finished Installation  07/28/1999 11:36:42

EXPECTED RESULT:
No errors from the Install.log.  The files are installed as specified from
Install.log.
One more thing...

I was remotely logged into a Linux machine from Solaris.  Could file/directory
permissions be a factor in these failures?
Assignee: cathleen → ssu
Target Milestone: M11
adding Dan to the CC list.
Summary: GetFolder: unixlocal and unixlib receive error -3 as target folders, respectively → [PP]GetFolder: unixlocal and unixlib receive error -3 as target folders, respectively
Putting on [PP] radar
Status: NEW → ASSIGNED
Summary: [PP]GetFolder: unixlocal and unixlib receive error -3 as target folders, respectively → [PP]GetFolder: unixlocal and unixlib incorrect error -3 as target folders, respectively
Target Milestone: M11 → M15
needs to be -215 for "you don't have permission to write to this"
Updated install scripts with Install.LogComment().  Error -3 is still being
returned.
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Keywords: pp
Summary: [PP]GetFolder: unixlocal and unixlib incorrect error -3 as target folders, respectively → GetFolder: unixlocal and unixlib incorrect error -3 as target folders, respectively
mass change to M16
Target Milestone: M15 → M16
need help verify
Assignee: ssu → jimmylee
Status: ASSIGNED → NEW
Build: 2000-05-08-11-M16(LINUX)

Changing Summary to indicate crash.  Changing Severity to critical.  Adding 
'crash' keyword.

After several attempts, I can rarely successfully install a_getfolder_2_unixlib.  
I have not successfully installed a_getfolder_1_unixlocal.  Most of the time, I 
simply crash when the progress dialog appears for a short time.

Incident ID = 10121254

Stack Trace
libraptorhtml.so + 0x1d16cf (0x40d0a6cf) 
libraptorhtml.so + 0x1ce99d (0x40d0799d) 
libraptorhtml.so + 0x1a551e (0x40cde51e) 
libraptorhtml.so + 0x1a1a84 (0x40cdaa84) 
libraptorhtml.so + 0x1a18f0 (0x40cda8f0) 
libraptorhtml.so + 0x288fde (0x40dc1fde) 
libraptorhtml.so + 0x2890e9 (0x40dc20e9) 
libraptorhtml.so + 0x288e2c (0x40dc1e2c) 
libraptorhtml.so + 0x1a551e (0x40cde51e) 
libraptorhtml.so + 0x328e82 (0x40e61e82) 
libraptorhtml.so + 0x329347 (0x40e62347) 
libraptorhtml.so + 0x1b2039 (0x40ceb039) 
libraptorhtml.so + 0x328d43 (0x40e61d43) 
libraptorhtml.so + 0x1a551e (0x40cde51e) 
libraptorhtml.so + 0x328e82 (0x40e61e82) 
libraptorhtml.so + 0x329347 (0x40e62347) 
libraptorhtml.so + 0x1b2039 (0x40ceb039) 
libraptorhtml.so + 0x328d43 (0x40e61d43) 
libraptorhtml.so + 0x1a551e (0x40cde51e) 
libraptorhtml.so + 0x328e82 (0x40e61e82) 
libraptorhtml.so + 0x329347 (0x40e62347) 
libraptorhtml.so + 0x1b2039 (0x40ceb039) 
libraptorhtml.so + 0x328d43 (0x40e61d43) 
libraptorhtml.so + 0x1a551e (0x40cde51e) 
libraptorhtml.so + 0x328e82 (0x40e61e82) 
libraptorhtml.so + 0x329347 (0x40e62347) 
libraptorhtml.so + 0x1b2039 (0x40ceb039) 
libraptorhtml.so + 0x328d43 (0x40e61d43) 
libraptorhtml.so + 0x1a551e (0x40cde51e) 
libraptorhtml.so + 0x1a53fc (0x40cde3fc) 
libraptorhtml.so + 0x1a53a2 (0x40cde3a2) 
libraptorhtml.so + 0x1ca065 (0x40d03065) 
libraptorview.so + 0x7eb3 (0x4102beb3) 
libraptorview.so + 0x15b2f (0x41039b2f) 
libraptorview.so + 0x15991 (0x41039991) 
libraptorview.so + 0x156c5 (0x410396c5) 
libraptorview.so + 0x16a90 (0x4103aa90) 
libraptorview.so + 0x7a5d (0x4102ba5d) 
libwidget_gtk.so + 0x2adfa (0x4051bdfa) 
libwidget_gtk.so + 0x2ad1d (0x4051bd1d) 
libwidget_gtk.so + 0x30e61 (0x40521e61) 
libwidget_gtk.so + 0x319e0 (0x405229e0) 
libwidget_gtk.so + 0x25a7b (0x40516a7b) 
libgtksuperwin.so + 0x1afa (0x4053aafa) 
libgdk-1.2.so.0 + 0x158ae (0x406658ae) 
libgdk-1.2.so.0 + 0x159be (0x406659be) 
libgdk-1.2.so.0 + 0x168b7 (0x406668b7) 
libgdk-1.2.so.0 + 0x16a94 (0x40666a94) 
libglib-1.2.so.0 + 0xf2c6 (0x406902c6) 
libglib-1.2.so.0 + 0xf801 (0x40690801) 
libglib-1.2.so.0 + 0xf979 (0x40690979) 
libgtk-1.2.so.0 + 0x85f3a (0x405c2f3a) 
libwidget_gtk.so + 0x1ed0a (0x4050fd0a) 
libnsappshell.so + 0x142ca (0x404412ca) 
mozilla-bin + 0x319c (0x0804b19c) 
mozilla-bin + 0x34b3 (0x0804b4b3) 
libc.so.6 + 0x17cb3 (0x4030ccb3)
Assignee: jimmylee → cathleen
Severity: normal → critical
Keywords: crash
Summary: GetFolder: unixlocal and unixlib incorrect error -3 as target folders, respectively → GetFolder: unixlocal and unixlib crash when triggered
This problem is likely a more general problem than specific to unixlocal and 
unixlib as I test more on this build.  But this one is fairly reproducible.
reassigning to doug.  :-)
reassigning...
Assignee: cathleen → dougt
I don't crash, but I do get a -229.  looking deeper....
Status: NEW → ASSIGNED
The tests cases here use the wrong forms of XPINSTALL marking invalid.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Yes, the original info provided on 7/28/99 is outdated for today.  Much has 
changed since July.

1. From http://jimbob/trigger3.html, click Acceptance drop-down menu and choose
   a_getfolder_1_unixlocal or a_getfolder_2_unixlib
2. Click Trigger case button

NOTE:
The new trigger page points to test cases that have been rewritten to use the 
new forms post Beta1.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I tried this, but my permissions were not set up:

     Acceptance: a_getfolder_2_unixlib
     ---------------------------------
 
     ** ERROR (-225): Installing: /usr/local/lib/netscape/getfolder_unixlib/smrt
updt.txt
     ** addFile returns = -225
 
     Install script aborted
     Finished Installation  05/09/2000 16:32:13
 
[dougt@y bin]$ touch /usr/local/lib/xxx
touch: /usr/local/lib/xxx: Permission denied

if you create a new directory and chown it:

[root@y bin]# mkdir /usr/local/lib/netscape/
[root@y bin]# mkdir /usr/local/lib/netscape/getfolder_unixlib/
[root@y bin]# chown dougt /usr/local/lib/netscape/getfolder_unixlib/

everything works fine:

     Acceptance: a_getfolder_2_unixlib
     ---------------------------------
 
     ** addFile returns = 0
     [1/1]      Installing: /usr/local/lib/netscape/getfolder_unixlib/smrtupdt.t
xt
 
     Install completed successfully
     Finished Installation  05/09/2000 16:36:05

Its a permissions problem.  marking as WORKSFORME
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Build: 2000-05-09-08-M16(LINUX)

What a difference a day makes.  Works for me with no crash.  Marking Verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.