Bookmark Deduplicator 1.2 doesn't work after landing patches from bug #1001090

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
4 years ago
7 months ago

People

(Reporter: Virtual, Assigned: jorgev)

Tracking

({addon-compat, nightly-community})

Firefox 35
x86_64
Windows 7
addon-compat, nightly-community

Firefox Tracking Flags

(firefox34 unaffected, firefox35 verified)

Details

(Whiteboard: [Fixed in Bookmark Deduplicator 1.3.1], URL)

Doesn't work in latest Nightly.
This error is shown in Error Console:

1411041145198	addons.xpi	WARN	Exception running bootstrap method startup on bookmarkdeduplicator@foxhatdev: TypeError: redeclaration of variable rootNode (resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/bookmarkdeduplicator@foxhatdev.xpi!/bootstrap.js -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/bookmarkdeduplicator@foxhatdev.xpi!/lib/deduplicateBookmarks.js:41:8) JS Stack trace: require@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/bookmarkdeduplicator@bootstrap.js:158:2 < @resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/bookmarkdeduplicator@foxhatdev.xpi!/bootstrap.js -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/bookmarkdeduplicator@main.js:13:11 < require@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/bookmarkdeduplicator@bootstrap.js:158:2 < startup@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/bookmarkdeduplicator@bootstrap.js:42:2 < XPI_callBootstrapMethod@XPIProvider.jsm:4434:9 < XPI_updateAddonDisabledState@XPIProvider.jsm:4557:1 < AddonWrapper_userDisabledSetter@XPIProvider.jsm:6887:9 < set_userDisabled@extensions.xml:1084:11 < oncommand@about:addons:1:1
[Tracking Requested - why for this release]: Regression - please mark this addon as not compatible with Firefox 35 and up, as it not works anymore from these versions due to bug #1001090
tracking-firefox35: --- → ?
Jorge - can you mark this not compatible?
Flags: needinfo?(jorge)
(Assignee)

Comment 3

4 years ago
Done. I also downgraded the add-on on the site to reduce its visibility.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jorge)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
status-firefox35: affected → verified
tracking-firefox35: ? → ---
@ Jorge Villalobos [:jorgev] - I'm requesting undo reduction Bookmark Deduplicator visibility, as newest version 1.3.1 works fine even in latest Nightly.
Incompatibility for older Bookmark Deduplicator versions than 1.3.1 can stay.
Flags: needinfo?(jorge)
Whiteboard: [Fixed in Bookmark Deduplicator 1.3.1]
(Assignee)

Comment 5

4 years ago
I'll give it a look, thanks.
Flags: needinfo?(jorge)
You need to log in before you can comment on or make changes to this bug.