Closed Bug 1069280 Opened 8 years ago Closed 8 years ago

Cache bug in FireFox 32 when posting forms with an offline manifest file

Categories

(Core :: Networking: Cache, defect)

32 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1065478

People

(Reporter: Marc, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140911151253

Steps to reproduce:

Create a simple application that accepts an HttpPost and returns a different content when the post is received.  Ensure the html tag includes a valid manifest attribute.


Actual results:

For some reason, FireFox 32 redisplays the form page instead of posting and displaying the response.  However, if I remove the manifest attribute, the post works correctly and displays the response.


Expected results:

The response page should be displayed.  This works in FireFox 31 as well as Safari, Chrome, and Internet Explorer (all versions).  FireFox 32 is broken (tested on Mac and Windows).
Component: Untriaged → Networking: Cache
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1065478
You need to log in before you can comment on or make changes to this bug.