Excel files uploaded with wrong mime type (Firefox 32.0.1)

RESOLVED DUPLICATE of bug 306471

Status

()

defect
RESOLVED DUPLICATE of bug 306471
5 years ago
3 years ago

People

(Reporter: mcintds, Unassigned)

Tracking

32 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140911151253

Steps to reproduce:

Create a form that allows for file upload.

Upload a Microsoft Excel 97-2003 Worksheet (.xls)

Check content type.


It appears as though the mimeTypes.rdf file lists Microsoft Excel 97-2003 Worksheet (and the NC:fileExtensions xls and csv) twice, vnd.ms-excel first, and x-download second.  The second declaration appears to be overriding the first and causing worksheets to come through with the wrong content type.


Actual results:

content type comes through as application/x-download


Expected results:

content type should have come through as application/vnd.ms-excel

Comment 1

5 years ago
Bugzilla allows attachments, so join directly a Microsoft Excel 97-2003 Worksheet to your bug report.
Flags: needinfo?(mcintds)
That is an old bug.....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373621
Flags: needinfo?(mcintds)

Updated

3 years ago
Duplicate of bug: 306471
You need to log in before you can comment on or make changes to this bug.