Closed Bug 1069438 Opened 8 years ago Closed 8 years ago

[Status Bar] Play icon sometimes shows up when camera in use icon is shown

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S7 (24Oct)
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: epang, Assigned: gmarty)

Details

(Whiteboard: [systemsfe] [2.1-flame-test-run-3])

Attachments

(1 file, 1 obsolete file)

46 bytes, text/x-github-pull-request
alive
: review+
Details | Review
Seems to be inconsistent when it shows up, but sometimes when the camera in use icon is shown the music play icon is also shown in the status bar. Note, there's no music being played, so there's no reason for the icon to appear.  Here are the steps I used that sometime make the icon show up.

STR:

1. Open camera app
2. Swtich to Video
3. Record
4. Press the home button
5. The status bar has the camera in use icon & the play button

I'm hoping QA can help with finding a way to reproduce this 100% of the time.
I can totally replicate this. The event 'audio-channel-changed' that shows the playing icon is fired. I don't really know what is responsible for that though.

Wilson, do you have any idea of what's wrong here?
Flags: needinfo?(wilsonpage)
Camera team has nothing to do with what is shown in the status bar. Sorry I can't be of more help :(
Flags: needinfo?(wilsonpage)
Actual Results: I can get this issue to occur a lot. The thing i noticed was that on Flame 2.2 KK and Flame 2.0 Base KK, the icon stayed around longer after the camera is closed. Other builds I saw it on show the play button almost every time i tapped the home button but only briefly. If you are having problems getting this bug to repro, try accessing the camera from the lock screen. It seems easier to get the bug to occur.

This bug repro's on Flame KK builds: Flame 2.2, Flame 2.1, Flame 2.0, Flame 2.0 Base KK, OpenC 2.2

Repro Rate: 9/13

Environmental Variables:
Device: Flame Master KK
BuildID: 20140919052449
Gaia: d170091ba1b5597b05f37fb259f6b8eb02568798
Gecko: 3475e6a1665a
Version: 35.0a1 (Master) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20140919050548
Gaia: f0f22bb46c881e02524b3991c2587ff8c0a9fc37
Gecko: ab2a88c05a4b
Version: 34.0a2
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20140919041249
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: fb1589259e4f
Version: 32.0 (2.0) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK Base
BuildID: 20140904160718
Gaia: 506da297098326c671523707caae6eaba7e718da
Gecko: 
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Device: Open_C 2.2
BuildID: 20140919052449
Gaia: d170091ba1b5597b05f37fb259f6b8eb02568798
Gecko: 3475e6a1665a
Version: 35.0a1 (2.2)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Tim, any idea why recording video would cause an `audio-channel-change` (changed to active) event?
Flags: needinfo?(timdream)
Redirecting to Alive since he understand more about audio channel than me.
Flags: needinfo?(timdream) → needinfo?(alive)
(In reply to Michael Henretty [:mhenretty] from comment #4)
> Tim, any idea why recording video would cause an `audio-channel-change`
> (changed to active) event?

recording will trigger audio channel service to work but I forgot the reason. Randy/Star confirm?
Flags: needinfo?(scheng)
Flags: needinfo?(rlin)
Flags: needinfo?(alive)
Do you mean this one? 
bug 811649 [camera] Start video recording, audio clip keeps on playing in background
Flags: needinfo?(rlin)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #6)
> (In reply to Michael Henretty [:mhenretty] from comment #4)
> > Tim, any idea why recording video would cause an `audio-channel-change`
> > (changed to active) event?
> 
> recording will trigger audio channel service to work but I forgot the
> reason. Randy/Star confirm?

While camera starting recording, it will occupy a "content" audio channel in order to stop any hidden "content" audio channel (i.e. content channel in background). The play icon actually is showed in the status bar, but it is covered because of camera preview mode (full screen). So user presses home key to back to home, the camera recording is stopped and the "audio-channel-change" is fired because of un-registering "content" channel.
Flags: needinfo?(scheng)
Assignee: nobody → gmarty
Attached file Github PR (obsolete) —
This patch makes sure no video recording is in progress before showing the playing icon.
Alive, can you review it?
Attachment #8498260 - Flags: review?(alive)
Comment on attachment 8498260 [details] [review]
Github PR

So according to comment 8 the behavior seems expected; we cannot tell the content  channel is coming from recording but can only make a guess.

I am not sure how urgent this is, but if someday we allow content to play with recording at the same time this may become a bug.

Please fix the unit test or add if there is no one.
Attachment #8498260 - Flags: review?(alive) → feedback+
Attached file Github PR
Hi Alive, thanks for the f+. I added a unit test so that in the future, if we want to enable audio playback while recording we can track this down.
Attachment #8498260 - Attachment is obsolete: true
Attachment #8505531 - Flags: review?(alive)
Attachment #8505531 - Flags: review?(alive) → review+
This happens 100% when recording a video on Flame 2.1

1. Open camera and switch to the camcorder.
2. Tap record and pull down the status bar.

The user can see the play icon and the recording icon. 

Flame 2.1 

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141015001201
Gaia: 379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Gecko: 4853208cb48a
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Whiteboard: [systemsfe] → [systemsfe] [2.1-flame-test-run-3]
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8505531 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Camera
[User impact] if declined: Confuse user by showing the playing icon in the status bar in addition to the recording icon when a video is being recorded
[Testing completed]: This patch is covered by unit test
[Risk to taking this patch] (and alternatives if risky): Very low (1 liner with comments) + unit tested
[String changes made]: None
Attachment #8505531 - Flags: approval-gaia-v2.1?(bbajaj)
Attachment #8505531 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Target Milestone: --- → 2.1 S7 (24Oct)
hi  Guillaume,
 we can also find the music play icon when we play a video.so could we let the icon show only when we play music other than any 'content' channel?
Flags: needinfo?(ryanvm)
sorry,NI Guillaume
Flags: needinfo?(ryanvm) → needinfo?(gmarty)
Hi, I'm not sure if that's a bug because we still need an indicator that a video is playing in the status bar. Redirecting the question to UX.
Rob, can you tell me if the play icon should only be shown in the status bar when a song is playing, and not on videos?
Flags: needinfo?(gmarty) → needinfo?(rmacdonald)
Flagging Jacqueline on this too.
Flags: needinfo?(jsavory)
Hi Guillaume... 

This icon was a partner requirement based on the following user story:

"As a user, when I exit the music application while the music is still playing I want to see a status bar indicating that music is still being played (both when screen is locked or unlocked)"

There was no corresponding video requirement.

As a result, the music play indicator should be displayed for music only. 

Thanks!
Rob
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
QA Contact: croesch
This issue is verified fixed on Flame 2.1 and 2.2.

Result: The music play icon does not appear when video is recording.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141114001204
Gaia: af6533781356acc62b0f40c9e040aa5b47d3b709
Gecko: 551326425826
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141114040205
Gaia: 1e300eac2e56d98ad51d414766d031db7d33221f
Gecko: bbb68df450c2
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.