Rocketbar no longer overlays results

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Assignee)

Description

3 years ago
On the latest master we no longer see rocketbar overlaying results, instead the app appears to disappear, and flashes when coming back into focus.
(Assignee)

Comment 1

3 years ago
Bisecting:

[~/workspace/gaia (master)]$ git bisect start
[~/workspace/gaia (master)]$ git bisect good 8ce472f7d79f1910404cd33081bd9cf537755665
[~/workspace/gaia (master)]$ git bisect bad 9acc56414195c8057e9b39dbb022741a0524c0aa
Bisecting: 65 revisions left to test after this (roughly 6 steps)
[429220431993b7f447a4dd4c750e20354ca17085] Merge pull request #24004 from chirarobert/fix_dialer_mess

git bisect good
Bisecting: 33 revisions left to test after this (roughly 5 steps)
[1c8eda05a2dcb58cf60d5ba506bd960ff988ba00] Merge pull request #24035 from shamenchens/Bug1061401-MultipleActivityWindow-2

git bisect good
Bisecting: 16 revisions left to test after this (roughly 4 steps)
[e2d70bee03b5380ac327a145e5d694fb2443f018] Merge pull request #24018 from yzen/bug-1066793

git bisect bad
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[4b650509b287b80fc88022f63a630d22a835e8d6] Merge pull request #23867 from wilsonpage/1065018

git bisect bad
Bisecting: 4 revisions left to test after this (roughly 2 steps)
[f5498c1ff6647d34460b1fb3495fc5d214d34ac3] Merge pull request #23937 from alivedise/bugzilla/1055299_master/v4

git bisect bad
Bisecting: 1 revision left to test after this (roughly 1 step)
[fcc35f58a87a2a4d21f9e30172f786a6b3afe2de] Merge pull request #23964 from albertopq/1063305-nfc-statusbar

git bisect good
Bisecting: 0 revisions left to test after this (roughly 0 steps)
[20b9139dfe494fa98f73d20aa4e42c13897fbddd] Bug 1055299: Ignore continuous app launch request in homescreen side and send homescreen to background while rocketbar is open in system side

git bisect bad
20b9139dfe494fa98f73d20aa4e42c13897fbddd is the first bad commit
commit 20b9139dfe494fa98f73d20aa4e42c13897fbddd
Author: Alive Kuo <alegnadise@gmail.com>
Date:   Wed Sep 3 01:32:01 2014 +0800

Bug 1055299: Ignore continuous app launch request in homescreen side and send homescreen to background while rocketbar is open in system side

:040000 040000 6375756efe30cf845e074361ce8cd5119440d1b8 9249aed556f167c64309b8878c8d04f87552bfd4 M	apps
:040000 040000 35c2a0e8dc60e0f26edfc05d664d9bfd1684cc74 3bfacb2ef4d95729fb2337fffdc208ae7aaec3c4 M	shared
(Assignee)

Comment 2

3 years ago
Confirmed that this has been caused by bug 1055299.
Blocks: 1055299, 1055065
No longer blocks: 1054414
(Assignee)

Comment 3

3 years ago
Fixed via revert of bug 1055299.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.