No memory card dialog is not exclusively visible.

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Music
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: yzen, Assigned: eeejay)

Tracking

(Blocks: 1 bug, {access})

unspecified
2.2 S7 (6mar)
All
Gonk (Firefox OS)
access

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Right now if the screen reader user opens a music app and gets a 'no sd card' dialog popup, they can still navigate to the screen underneath it, even though the dialog is supposed to hide then. This should be fixed.

Comment 1

3 years ago
Created attachment 8560168 [details] [review]
[PullReq] eeejay:bug-1069611 to mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → eitan
(Assignee)

Comment 2

3 years ago
Comment on attachment 8560168 [details] [review]
[PullReq] eeejay:bug-1069611 to mozilla-b2g:master

Passes tests, and ready for review.
Attachment #8560168 - Flags: review?(dkuo)

Comment 3

3 years ago
Comment on attachment 8560168 [details] [review]
[PullReq] eeejay:bug-1069611 to mozilla-b2g:master

Eitan, the code looks good to me, however I have a suggestion on github, please take a look and feel free to adopt it or not.

I am not familiar with the gaia-ui-tests, so setting additional review to Johan, thanks.
Attachment #8560168 - Flags: review?(jlorenzo)
Attachment #8560168 - Flags: review?(dkuo)
Attachment #8560168 - Flags: review+
Comment on attachment 8560168 [details] [review]
[PullReq] eeejay:bug-1069611 to mozilla-b2g:master

The test looks really simple, the manifest is correctly filled, I don't see any major reason to not merge this test in our code base.

One small minor nit in it though.
Attachment #8560168 - Flags: review?(jlorenzo) → review+
(Assignee)

Comment 5

3 years ago
https://github.com/mozilla-b2g/gaia/commit/5693ecba5e54062700b77e3d4e5a0a12f969edcc
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 years ago
Comment on attachment 8560168 [details] [review]
[PullReq] eeejay:bug-1069611 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Music interface will be operable via screen reader even when the overlay is blocking it.
[Testing completed]: Yes. We also have a python ui test.
[Risk to taking this patch] (and alternatives if risky): Very low.
[String changes made]: None.
Attachment #8560168 - Flags: approval-gaia-v2.2?
(In reply to Eitan Isaacson [:eeejay] from comment #6)
> Comment on attachment 8560168 [details] [review]
> [PullReq] eeejay:bug-1069611 to mozilla-b2g:master
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #):
> [User impact] if declined: Music interface will be operable via screen
> reader even when the overlay is blocking it.
> [Testing completed]: Yes. We also have a python ui test.
> [Risk to taking this patch] (and alternatives if risky): Very low.
> [String changes made]: None.

I am approving this as an exception, but please note we are limiting changes on 2.2 and will no longer be approving non-blockers to help converge and stabilize in the next few weeks.

Updated

3 years ago
Attachment #8560168 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/e346140b7633470d23e768097c07e75694929f0f
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.