Repeat button should be a toggle button.

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Music
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: yzen, Assigned: eeejay)

Tracking

({access, late-l10n})

unspecified
2.2 S7 (6mar)
All
Gonk (Firefox OS)
access, late-l10n

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Repeat button should have toggle button semantics so the screen reader user knows what state it is on.

Comment 1

4 years ago
The repeat button isn't a toggle button, though. It's a 3-state button that cycles through "don't repeat", "repeat the whole playlist", and "repeat the current song".

Comment 2

4 years ago
How is that communicated visually? Is there an actual label change when the button is touched, or is this all indicated via a graphical representation? If the former, we should make sure that the screen reader always gets the current label. If the latter, we need to come up with labels that communicate the current status so the user knows what the repeat is set to. A tri-state checkbox doesn't make sense, either, since it is hard to tell which state would be unchecked (OK, that's still easy), half-checked, and fully checked.
(Assignee)

Comment 3

3 years ago
I'm going to have the name of the button change depending on mode:
1. Repeat off
2. Repeat all
3. Repeat track
Created attachment 8562359 [details] [review]
[PullReq] eeejay:bug-1069629 to mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → eitan
(Assignee)

Updated

3 years ago
Attachment #8562359 - Flags: review?(squibblyflabbetydoo)

Comment 5

3 years ago
Comment on attachment 8562359 [details] [review]
[PullReq] eeejay:bug-1069629 to mozilla-b2g:master

I don't know much about ARIA, but this looks ok. See my comment on GitHub though.
Attachment #8562359 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 6

3 years ago
Thanks! Comment addressed.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8562359 [details] [review]
[PullReq] eeejay:bug-1069629 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Repeat button will not be labeled, and the user won't know what mode it is in with a screen reader.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: Yes, labels added.
Attachment #8562359 - Flags: approval-gaia-v2.2?
(Assignee)

Updated

3 years ago
Keywords: late-l10n

Updated

3 years ago
Attachment #8562359 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/e40f1ba227436231715c69fec57b423ad18eec1c
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.