image zoom doesn't work after right-click

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
3 years ago
11 days ago

People

(Reporter: Djfe, Unassigned)

Tracking

32 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140911151253

Steps to reproduce:

Get Image that is bigger than your screen resolution
Open image in Firefox
you will see a plus icon as a mouse symbol while hovering over it
right-click to get the context menu
try to click on the image to zoom in


Actual results:

the symbol changes to a minus symbol but the image stays zoomed out

you can click as much as you want, the only thing changing is the mouse symbol

if you reload the page and click on the image directly after that it zooms in
press again -> zoom out
etc.
press right-click to open context-menu, click again on the image -> the zoom works


Expected results:

the issue above only happens for the first right-click press in the image viewer
press a different mouse key and the zoom after that will work fine even if you press right-click

Hopefully you can fix this small issue in the next version.

I'm not sure about the component that is affected by this.
Maybe the image lib.

I'm using Windows 7 64bit at the moment and the newest official release in the 32 branch.

Regards,
Felix
wfm with Firefox32 and Firefox trunk on Windows7 and this image : http://mversen.de/mozilla/bigimage.jpg
Component: General → Untriaged
(Reporter)

Comment 2

3 years ago
OK actually I found out that this issue is caused by Image Zoom:
https://addons.mozilla.org/de/firefox/addon/image-zoom/

I reported the issue on the project's github page:
https://github.com/jasadams/imagezoom/issues/22

But I don't think that it will ever be fixed, because the last commits happened over a year ago...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.