[OPEN C][BLUETOOTH]DUT can't start discovery when a pair request is denied.

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: yang.xiaohong, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MALC; .NET4.0C; .NET4.0E; Zune 4.7; InfoPath.2; TCO_20140919080501)

Steps to reproduce:

1. DUT start a pair request, and click ok to pair.
2. The other device click cancel to deny pair request.
3. Check DUT , there is no prompt to tell user the pair request failed. (There should be a prompt)
4. DUT cant start another pair request. (I want to start pair request agian, but nothing happened. )



Expected results:

3. There should be a prompt to tell user the pair request has be denied.
4. The DUT should can start another pair request instend of doing nothing.
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)
Priority: -- → P2
Hardware: All → ARM
Which release do you use? v2.0 or v2.1?
Flags: needinfo?(yang.xiaohong)
(Reporter)

Comment 2

4 years ago
hi Shawn,
We use FFOS V1.3.
Bluetooth 4.0.
Flags: needinfo?(yang.xiaohong)
Keep ni? me to check.
Flags: needinfo?(shuang)
qawanted to confirm whether this bug occurs on Aries/Flame with the latest m-c.
Keywords: qawanted
This bug can't be repro on the latest Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: On sending request side the prompt "Unable to pair devices" will pop up to tell user the pairing request has be denied, and user can start another pair request again.

See attachment: verify_FlameKK_v2.5.3gp
Reproduce rate: 0/15


Device: Flame KK 2.2 (Unaffected) 
Build ID               20150817032503
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/82ec88fa015c
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150817.065716
Firmware Date          Mon Aug 17 06:57:27 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Unaffected)
Build ID               20150817150206
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9673c75864beafca2f6c8b117b98503128bf2e56
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150817.182933
Firmware Date          Mon Aug 17 18:29:45 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Unaffected)
Build ID               20150818005621
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6ae3e9ff53b2bae8d95a90c9f25368fd81fa357e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150818.003312
Firmware Date          Tue Aug 18 00:33:21 UTC 2015
Bootloader             s1
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → unaffected
Keywords: qawanted
Created attachment 8649119 [details]
verify_FlameKK_v2.5.3gp
Resolve as WONTFIX since the bug doesn't reproduce on the latest m-c per comment 5. Please reopen for any further concern.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.