If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Extra empty lines in install.rdf causes failure of Bulgarian localization xpi for Firefox

RESOLVED DUPLICATE of bug 1025437

Status

Mozilla Localizations
bg / Bulgarian
RESOLVED DUPLICATE of bug 1025437
3 years ago
3 years ago

People

(Reporter: Deyan Stoykov, Assigned: Ognyan Kulev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Steps to reproduce:

Attempt to install Bulgarian localization xpi for Firefox 31.0 from:

http://download-origin.cdn.mozilla.net/pub/mozilla.org/firefox/releases/31.0/win32/xpi/bg.xpi


Actual results:

The xpi is not installed. Error message:

The add-on downloaded from ... could not be installed because it appears to be corrupt.


Expected results:

The xpi should be installed. 

The workaround is to unpack the xpi, remove two empty lines from the beginning of install.rdf, repack and retry.
Confirmed with fx34
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025437

Comment 3

3 years ago
Oh my, I reported this issue back in 2014-06-13 https://bugzilla.mozilla.org/show_bug.cgi?id=1025437
I thought it was long lost as it never got replied to until recently.

This bug has been present for a long time.
You need to log in before you can comment on or make changes to this bug.