Closed Bug 1069819 Opened 5 years ago Closed 5 years ago

Update newsblog to address non-backward compatible changes to JS let semantics

Categories

(MailNews Core :: Backend, defect)

defect
Not set

Tracking

(thunderbird35?, thunderbird36 fixed, seamonkey2.32 fixed, seamonkey2.33 fixed)

RESOLVED FIXED
Thunderbird 36.0
Tracking Status
thunderbird35 ? ---
thunderbird36 --- fixed
seamonkey2.32 --- fixed
seamonkey2.33 --- fixed

People

(Reporter: philip.chee, Assigned: aryx)

References

Details

Attachments

(1 file, 1 obsolete file)

Fri Sep 19 2014 15:50:49
Error: ReferenceError: can't access let declaration `tags' before initialization
Source file: chrome://messenger-newsblog/content/feed-parser.js
Line: 133
Attached patch patch, v1 (obsolete) — Splinter Review
Patch fixes the issue in a locally compiled build. Filed bug 1069841 about the error complaining about the wrong line.
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #8492085 - Flags: review?(standard8)
Attachment #8492085 - Flags: review?(standard8) → review+
https://hg.mozilla.org/comm-central/rev/a06eb125f40d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
Duplicate of this bug: 1082752
Duplicate of this bug: 1089360
With Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Thunderbird/35.0a2 ID:20141030004004 CSet: 1238fbdc3cc8 adding a new feed url still doesn't work. It hangs while verifying the feed.
Duplicate of this bug: 1092569
Comment on attachment 8492343 [details] [diff] [review]
patch, v2, r=Standard8

Possible SM point release 2.32.1
[Approval Request Comment]
Regression caused by (bug #): non-backward compatible changes to JS let semantics
User impact if declined: issues updating certain RSS feeds
Testing completed (on c-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): None
Attachment #8492343 - Flags: approval-comm-release?
> Possible SM point release 2.32.1
> [Approval Request Comment]
> Regression caused by (bug #): non-backward compatible changes to JS let
> semantics
> User impact if declined: issues updating certain RSS feeds
> Testing completed (on c-c, etc.): Yes
> Risk to taking this patch (and alternatives if risky): None

Thunderbird does releases off their ESR branch. They don't care about relbranches on comm-release. I guess we can go with a+ from a SeaMonkey peer.
Flags: needinfo?(iann_bugzilla)
Comment on attachment 8492343 [details] [diff] [review]
patch, v2, r=Standard8

Well I would say a=me but I cannot set a+ on mailnews components.
Flags: needinfo?(iann_bugzilla)
a=IanN/Ratty for SeaMonkey 2.32.1 relbranch comm-release on CLOSED TREE
http://hg.mozilla.org/releases/comm-release/rev/26dc15bce34b
You need to log in before you can comment on or make changes to this bug.