Custom toolbox panel should be removed when the parent extension is disabled

RESOLVED WORKSFORME

Status

Add-on SDK
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Honza, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [firebug-p1])

(Reporter)

Description

4 years ago
Custom toolbox panel coming from an extension should be automatically removed when the extension is disabled.

STR:

1) Install debug-client extensions (in SDK example dir)
2) Open the toolbox, there is Ladybug panel
3) Go to add-on manager (Ctrl+Shift+A) and disable the extension
4) The panel should be removed it isn't -> BUG


Honza
(Reporter)

Updated

4 years ago
Whiteboard: [firebug-p1]
(Reporter)

Comment 1

4 years ago
Any tips what could be wrong here?

Honza
Flags: needinfo?(rFobic)
It does seem to work as expect for me, can you see if there are any errors logged into browser console or in the terminal ?
Flags: needinfo?(rFobic)
(Reporter)

Comment 3

4 years ago
I can't reproduce this anymore, closing.

Honza
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.