unable to enter sync by one tap after configure firefox account

RESOLVED WORKSFORME

Status

()

Firefox for Android
Android Sync
RESOLVED WORKSFORME
4 years ago
8 months ago

People

(Reporter: Peipei Cheng (needinfo if you need my action), Unassigned)

Tracking

({reproducible})

Firefox 35
Other
Android
reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce
-------------------------------------------------------------------------------
1. Install and Launch Fennec
2. go to Settings->Sync
3. Follow the steps to Login to Firefox Account
4. After login, return to browse
5. Go to Setting->Sync
   -> Unable to open Sync page by one tap on "sync" item.

This issue is reproducible on nightly too.

Updated

4 years ago
Component: General → Android Sync
Product: Firefox for Android → Android Background Services
Version: Firefox 33 → Firefox 35

Updated

4 years ago
Keywords: reproducible
I think this has reared its head before. rnewman, liuche: there was some activity/preferences/tap handler interaction in the past.  Can you recall anything more?
Flags: needinfo?(rnewman)
Flags: needinfo?(liuche)
I already have an account set up on the only device nearby, so I can't follow the STR, but I can't reproduce by Settings > Sync > Terms of Service > Settings > Sync, which *should* be equivalent.

What happens when you tap Sync?
Flags: needinfo?(rnewman)
I just tried this on a developer build and Nightly, and it looks like the very first time I try to access the Sync Settings from Settings, I need to tap "Sync" twice.

The logs say that we try to launch FxAccountGetStarted (nothing displays, because we have a sync account), but then I never see the "START FxAccountStatusActivity" message that should pop up.

09-19 16:41:29.516: I/ActivityManager(377): START u0 {flg=0x10000000 cmp=org.mozilla.fennec_liuche/org.mozilla.gecko.fxa.activities.FxAccountGetStartedActivity} from pid 23533
09-19 16:41:29.516: W/ActivityManager(377): Activity is launching as a new task, so cancelling activity result.

On subsequent taps of "Sync," I do see a log statement that FxAccountStatusActivity is starting up. It seems like FxAccountGetStarted isn't redirecting the new intent to launch Sync settings correctly? I also tried swipe-closing the final setup screen to see if having that open was somehow related or interfering with handling the new intent, but this just caused Fennec to restart when I switched to it.
Flags: needinfo?(liuche)
Oh, and with respect to your question about tap handling, I don't recall anything related to handling Preference clicks - there were problems opening Settings before, but that was on 2.3 (bug 1058027) or tablets (bug 966784) and specifically related to getting the Settings activity to even open.

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME

Updated

8 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.