Enforce required fields during contact validation in LoopContacts.jsm

RESOLVED DUPLICATE of bug 1099950

Status

Hello (Loop)
Client
P2
normal
RESOLVED DUPLICATE of bug 1099950
3 years ago
3 years ago

People

(Reporter: mikedeboer, Unassigned, Mentored)

Tracking

unspecified
Points:
2
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [contacts])

We'll need to enforce fields to be required that are absolutely necessary for the Loop client to function properly.
At the moment, according to the MVP UX spec, the fields required would be 'name' and 'email'. Please don't take this as a reference as the requirement(s) might chance once this bug gets implemented.
Flags: qe-verify-
Flags: firefox-backlog+
Mike -- Has this already been handled in other bugs?
backlog: --- → Fx35?
Flags: needinfo?(mdeboer)
Nope.
Flags: needinfo?(mdeboer)

Comment 3

3 years ago
validate that name, email have valid input, also phone number once that bug is input to make sure we are sending proper info to server.
backlog: Fx35? → Fx35+
Priority: -- → P1

Comment 4

3 years ago
Hi Paolo, can you take this bug?  looking during planning meeting to find owners for P1's for this sprint.  there are several other bugs available as well - but just asking for this one.  Mike is on PTO for a couple of days (injured his hand = 12 stitches), but Jared is available if questions on area.
Flags: needinfo?(paolo.mozmail)

Comment 5

3 years ago
Hi Shell, from the bug description it's not clear to me why we need to do this in LoopContacts.jsm at the API level at this stage of the project, and what the interaction would be with various callers or synchronization. Can we rephrase this in terms of what we expect in terms of UX? Isn't the current behavior the correct one already, without any action required here?
Flags: needinfo?(paolo.mozmail)
We want to make sure that the contact info added is formatted correctly (such that the system can use it) before the contact info saved and the user leaves the contact entry dialog. If the user has made a typo that we can flag to him/her before the entry is saved, that is a win for the user.

Mike -- am I describing the issue we're trying to fix/improve correctly?

I did just checked in Nightly, and the system will not let me save an entry unless the email address is formatted as "foo@bar" so there is some validation being done.  Perhaps that is enough, and this can wait until Fx37?
Flags: needinfo?(mdeboer)
It can wait. This bug is about enforcing data consistency, regardless of input method, so that no incomplete objects may ever be stored in the database.
Flags: needinfo?(mdeboer)
Thanks for clarifying, Mike.  

Let's triage this as part of Fx37.
backlog: Fx35+ → Fx37?

Updated

3 years ago
Whiteboard: [contacts] [qa-] → [contacts]

Comment 9

3 years ago
Hi Sevaan, we don't have a UX for how to handle needing name and email OR phone number.  and we need to validate email and phone to make sure they are formatted well.  there was a red box discussion with JAWS about how to handle the red box for mandatory when it's either/or

just added darrin in case this was already done in another bug.
backlog: Fx37? → Fx38+
Flags: needinfo?(sfranks)
Flags: needinfo?(dhenein)
Priority: P1 → P2
I believe this work has been done in Bug 1099950.
Flags: needinfo?(sfranks)
Flags: needinfo?(dhenein)

Comment 11

3 years ago
duping to bug 1099950 as that has the UX and one other fix request
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1099950
You need to log in before you can comment on or make changes to this bug.