The system app is constantly restyling when an update is available

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: etienne, Assigned: etienne)

Tracking

unspecified
2.1 S5 (26sep)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
The root cause is bug 962594, but the animation in question is actually *never* displayed since the utility tray was visually refreshed.

Patch incoming.
(Assignee)

Updated

3 years ago
Depends on: 1038723
(Assignee)

Comment 1

3 years ago
Created attachment 8492235 [details] [review]
Gaia PR

This patch is implementing the progress to spec and by the same occasion fixing the constant restyle.
Assignee: nobody → etienne
Attachment #8492235 - Flags: review?(21)
(Assignee)

Comment 2

3 years ago
Created attachment 8492238 [details]
2014-09-19-18-18-42.png

currently on master 2.1 while the update is downloading the notification doesn't show anything. This patch is adding it according to https://mozilla.app.box.com/s/yek8hkezu40yjwix4dca, we don't have a progress value so we're displaying the "looping" indicator.
Attachment #8492238 - Flags: ui-review?(epang)
(Assignee)

Comment 3

3 years ago
[Blocking Requested - why for this release]:
Details can be found on bug 962594, but to sum up: when an update (system update or app update) is availablem the system app will never be idle (constant restyle) and will drain the battery.

Worse, the element causing this is never displayed on screen..
And we have no activity indicator while downloading an update so we're not matching the spec.

Thankfully, a small CSS patch fixes all of this, I'd ask for approval but I think we should block here because of the power consumption issue.
blocking-b2g: --- → 2.1?
Major power issue.
blocking-b2g: 2.1? → 2.1+
(In reply to Etienne Segonzac (:etienne) from comment #2)
> Created attachment 8492238 [details]
> 2014-09-19-18-18-42.png
> 
> currently on master 2.1 while the update is downloading the notification
> doesn't show anything. This patch is adding it according to
> https://mozilla.app.box.com/s/yek8hkezu40yjwix4dca, we don't have a progress
> value so we're displaying the "looping" indicator.

Hey Etienne, this looks good, but while updating the progress indicator for browser we found that an animated GIF worked better.  Here's a link to the gifs: https://mozilla.box.com/s/o9y1vczu97ehfwtpgnhz

Can we update so they match? Thanks!
Flags: needinfo?(etienne)
(Assignee)

Comment 6

3 years ago
I'm pretty sure we're already using this gif :)
Flags: needinfo?(etienne)
(Assignee)

Comment 7

3 years ago
(In reply to Etienne Segonzac (:etienne) from comment #6)
> I'm pretty sure we're already using this gif :)

I meant we're using the only one present in the system app.
Comment on attachment 8492238 [details]
2014-09-19-18-18-42.png

great, in that case this is good :).  Thanks Etienne!
Attachment #8492238 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Comment 9

3 years ago
https://github.com/mozilla-b2g/gaia/commit/4baea432fe0486b56823f2e9cb5272ffb46360d2
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
(Assignee)

Comment 10

3 years ago
Comment on attachment 8492235 [details] [review]
Gaia PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): the update manager, here since 1.0
[User impact] if declined: poorer battery life
[Testing completed]: checked that the constant restyle is fixed, checked that the system update notification is still working properly, checked that the new progress indication is displaying properly
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: zilch
Attachment #8492235 - Flags: approval-gaia-v2.1?

Updated

3 years ago
Attachment #8492235 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/93a99bea0b40d81bd063f7d8b1964dc1ba35ba7b
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.1 S5 (26sep)
verifyme on 2.1 branch
Keywords: verifyme
Verified fixed on Flame 2.1 and Flame 2.2.

Result: Download progress indicator is displayed while downloading an update.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.2

Device: Flame Master (319mb)(KitKat Base)(FullFlash)
BuildID: 20141023040204
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.