Closed Bug 1070006 Opened 8 years ago Closed 8 years ago

[calendar] unit test change chai.assert api in the new version

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

defect
Not set
normal

Tracking

(b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S5 (26sep)
Tracking Status
b2g-v2.2 --- fixed

People

(Reporter: sv99, Assigned: sv99)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140917114326

Steps to reproduce:

test_agent used very old version chai library version=0.5.3
in the current version=1.9.1 same api chenged 

1. assert.length -> assert.lengthOf
2. assert.deepEqual(arguments, [x,x, ... ]) -> assert.deepEqual(Array.slice(arguments))
Comment on attachment 8492256 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24227

Redirecting to a peer for Calendar.

Hey Kevin, the goal is to move to a newer Chai which has issues with some of the test code we use currently. Looks like the changes are backward compatible and Gu is still green, but maybe you want to look closer :)
Attachment #8492256 - Flags: review?(felash) → review?(kgrandon)
Depends on: 1070047
Blocks: 1070047
No longer depends on: 1070047
Comment on attachment 8492256 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24227

Gu is green so I am happy and will leave an R+ here. Thanks!
Attachment #8492256 - Flags: review?(kgrandon) → review+
Assignee: nobody → sv99
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/ab732d719c94f16bf65f54032519e8d015d93226
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S5 (26sep)
You need to log in before you can comment on or make changes to this bug.