All users were logged out of Bugzilla on October 13th, 2018

Consolidate notes for upgraders into a single page

RESOLVED FIXED

Status

()

--
enhancement
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

Details

Attachments

(1 attachment)

The docs say "read the Release Notes information for upgraders before upgrading", but this information is not at all easily accessible. The latest release notes file is:
http://www.bugzilla.org/releases/4.4.5/release-notes.html
which only goes back to 4.0; for before that, you have to read...
<breaks off to file bug 1070134 about link at the bottom of that page not working>
...something like https://bugzilla.mozilla.org/page.cgi?id=release-notes3.html . And the information important to upgraders is dotted throughout those very long files. We should consolidate it all in one place, so we can link that page from the docs and save people a lot of time.

Gerv
Duplicate of this bug: 1070132

Updated

4 years ago
Severity: normal → enhancement
dkl: are you OK with this idea?

Gerv
Flags: needinfo?(dkl)
(In reply to Gervase Markham [:gerv] from comment #2)
> dkl: are you OK with this idea?
> 
> Gerv

Sounds good to me. Just pushed a fix to bugzilla.org for the bad page.cgi link issue FWIW.

dkl
Flags: needinfo?(dkl)
Created attachment 8526783 [details]
upgrade-notes.html

Here's a page which would do. I went through all the old release notes, extracting the bits which were relevant to upgrading admins - i.e. manual steps or breaking changes. This file would go in docs/upgrade-notes.html, and we could link it from the docs as an unchanging URL, adding to it whenever we release a new version.

Gerv
Assignee: website → gerv
Status: NEW → ASSIGNED
Attachment #8526783 - Flags: review?(dkl)
Comment on attachment 8526783 [details]
upgrade-notes.html

r=dkl
Attachment #8526783 - Flags: review?(dkl) → review+
Hmm. Looks like I accidentally checked this in already, probably when I checked in the other pile of docs. Oh, well :-)

http://www.bugzilla.org/docs/upgrade-notes.html

dkl: can you add a note to the release process to update this page with relevant info, and make sure it's linked from the release announcements?

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.