[Settings] Extra hairline in settings menu - USB storage

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
--
trivial
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: amylee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ux-tracking, visual design)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8492372 [details]
2014-09-19-15-31-34.png

Steps to reproduce:

1. Open settings app
2. Scroll down to USB storage 

There is a vertical hairline next to the toggle button that should be removed.
(Reporter)

Updated

3 years ago
Component: Gaia::Camera → Gaia::Settings

Comment 1

3 years ago
This appears to be an intentional.

"have split switch" in https://github.com/mozilla-b2g/gaia/commit/8968aa0019340e9b2837046784a231f57728c303, by bug 964601.
Blocks: 964601
Severity: normal → trivial
Priority: P1 → --

Comment 2

3 years ago
Yes, it's an intentional split to distinguish the toggle and the panel function.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

3 years ago
(In reply to Fred Lin [:gasolin] from comment #2)
> Yes, it's an intentional split to distinguish the toggle and the panel
> function.

It seems strange that only USB storage has the hairline but Airplane Mode, Geolocation, and NFC don't since they also have a toggle switch. NI Helen for feedback.
Flags: needinfo?(hhuang)

Comment 4

3 years ago
When you tap usb storage panel (left) instead of the switcher, you will go to the transfer protocol selection panel. But Airplane Mode, Geolocation, and NFC doesn't.
(Reporter)

Comment 5

3 years ago
(In reply to Amy Lee [:amylee] from comment #3)
> (In reply to Fred Lin [:gasolin] from comment #2)
> > Yes, it's an intentional split to distinguish the toggle and the panel
> > function.
> 
> It seems strange that only USB storage has the hairline but Airplane Mode,
> Geolocation, and NFC don't since they also have a toggle switch. NI Helen
> for feedback.

Okay thanks for the clarification. This bug can be closed.
Flags: needinfo?(hhuang)
You need to log in before you can comment on or make changes to this bug.