Closed Bug 1070146 Opened 5 years ago Closed 5 years ago

Resource timing for scripts has responseStart and several attributes set to 0

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: valentin, Assigned: valentin)

References

Details

Attachments

(1 file)

http://w3c-test.org/resource-timing/test_resource_timing.html

The test for resource_timing_test0.js fails and several of its attributes are 0.
Also, looking at the entries for the other scripts - same thing.

This is clearly a bug.
It seems that channels for .js and .ico files have a null loadInfo, so nsPerformanceTiming::CheckAllowedOrigin returns false.
http://dxr.mozilla.org/mozilla-central/source/dom/base/nsPerformance.cpp#93

Is this the correct behaviour or a known issue?
Flags: needinfo?(bzbarsky)
Correction: only the .js channels have a null loadInfo.
> Is this the correct behaviour or a known issue?

More of the latter, I think.  Right now, all sorts of channels have no loadinfo.  See bug 1038756, which ought to help.
Flags: needinfo?(bzbarsky)
I have tested with the patches from bug 1038756 and the attributes are no longer 0.
Will retest and close this bug once that lands (seems to be very close).
Depends on: 1038756
Bug 1038756 landed and fixed this issue. Adding test to prevent future regressions.
Attachment #8494112 - Flags: review?(bzbarsky)
Comment on attachment 8494112 [details] [diff] [review]
Test resource timing info for script resources

r=me
Attachment #8494112 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/da5c4c9ee9b6
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.