Define and document the API for add-on signing

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Code Quality
P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: clouserw, Assigned: rtilder)

Tracking

Details

(Reporter)

Description

4 years ago
To sign add-ons according to the plan[1] we need to pass in at least the add-on ID to Trunion so it can put that into the cert as part of the Common Name.

After the signing is done, AMO needs to know the certificate serial number.  We could pull this out of the returned add-on, or if Trunion is returning a blob to us anyway, we could put it in there.

In short, we need to document what the ins and outs should look like. :)

[1] https://docs.google.com/a/mozilla.com/document/d/1KhpDteoHFmVRkzlrT8v0N3F-KrPxLoZFM3mWmEmOses/edit
(Reporter)

Updated

4 years ago
Blocks: 1070189
(Reporter)

Updated

4 years ago
Blocks: 1070190
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1047252
(Reporter)

Comment 3

4 years ago
is there more to do on this bug?
(Assignee)

Comment 4

4 years ago
Nope.  Should have been closed months ago.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.