Call the Trunion API to sign add-ons when approved

RESOLVED FIXED in 2015-01

Status

P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: clouserw, Assigned: aspyrine)

Tracking

unspecified
2015-01
Dependency tree / graph

Details

(Whiteboard: [qa-])

(Reporter)

Description

4 years ago
When an add-on gets approved we move it out of /guarded-addons/ and into /files/ and /public-staging/ (if I recall correctly).  As part of the approval process, when an editor approves an add-on we need to call the Trunion API and make sure the package gets signed and then copy that new package to /files/ and /public-staging/.

If you're not familiar with the nomenclature here I can help run through what approving an add-on looks like.  The queues are at a.m.o/editors/
(Reporter)

Comment 1

4 years ago
Putting this behind a waffle flag would be a good idea.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1047261
(Assignee)

Updated

4 years ago
Assignee: nobody → olivier
(Assignee)

Comment 3

4 years ago
It needs to be reviewed.

https://github.com/mozilla/olympia/pull/353
Fixed in https://github.com/mozilla/olympia/commit/6c72c7115419a1dd6d6fae099c436fa4d32a0e3f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
Target Milestone: --- → 2015-01
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.