Closed Bug 1070433 Opened 5 years ago Closed 5 years ago

"Emulate device" abilities for web developer

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1028905

People

(Reporter: Phyks, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140906030204

Steps to reproduce:

Hi,

Chromium has advanced emulation abilities in its devtools, which could be really interesting for webapp development in Firefox.

Among them :
* Emulation of device pixel ratio, and viewport meta, to get the same view on a desktop browser as on a mobile device.
* Choose the CSS media to use for styling (to have a live render of a print CSS for instance)
* Ability to spoof the user agent directly in the devtools
* Emulation of sensors. Geolocation is already handled by bug https://bugzilla.mozilla.org/show_bug.cgi?id=1069882, but accelerometer and so could be emulated as well.

What do you think about it ?
Component: Untriaged → Developer Tools
OS: Linux → All
Hardware: x86_64 → All
The bits that are "new" in Chrome are covered by bug 1028905.  Several APIs, like geolocation and others have their own bugs.  If there are specific ones you'd like to see emulated please file specific bugs about them if they do not exist already.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Summary: "Emulate device" abilities for web developper → "Emulate device" abilities for web developer
Duplicate of bug: emulation-devtools
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.