"Assertion failure: !ins->hasDefUses()" with ion-eager in browser

VERIFIED DUPLICATE of bug 1073861

Status

()

Core
JavaScript Engine: JIT
--
critical
VERIFIED DUPLICATE of bug 1073861
3 years ago
3 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({assertion, regression})

Trunk
x86_64
Mac OS X
assertion, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8492567 [details]
stack

With:
  user_pref("javascript.options.ion.unsafe_eager_compilation", true);

starting Firefox hits:

Assertion failure: !ins->hasDefUses(), at /Users/jruderman/trees/mozilla-central/js/src/jit/TypePolicy.cpp:269
Most likely fixed with bug 1073861
Depends on: 1073861
Can you confirm this bug is fixed?
Flags: needinfo?(jruderman)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jruderman)
Resolution: --- → DUPLICATE
Duplicate of bug: 1073861
(Reporter)

Comment 4

3 years ago
I can now start Firefox with ion eager. And with baselinejit eager. Thanks, Hannes!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.