crash in nsImapIncomingServer::GetMsgFolderFromURI [Mac]

REOPENED
Unassigned

Status

Thunderbird
General
--
critical
REOPENED
4 years ago
a year ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash, regression, regressionwindow-wanted})

31 Branch
All
Mac OS X
crash, regression, regressionwindow-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB??], crash signature)

(Reporter)

Description

4 years ago
#55 crash for TB31.1.1
rare crashes in 24.5.0 and 24.6.0
marked increase in version 31.0 [1].

So what caused the increase? 
And is there a windows+linux equivalent crash signature?

This bug was filed from the Socorro interface and is 
report bp-138d0abd-da81-49b4-a8d9-7b6eb2140910 31.1.1
=============================================================
 0 	XUL	nsCOMPtr_base::assign_with_AddRef(nsISupports*)	xpcom/glue/nsCOMPtr.cpp
1 	XUL	nsImapIncomingServer::GetMsgFolderFromURI(nsIMsgFolder*, nsACString_internal const&, nsIMsgFolder**)	objdir-tb/x86_64/mozilla/dist/include/nsCOMPtr.h
2 	XUL	nsImapIncomingServer::SetDeleteModel(int)	mailnews/imap/src/nsImapIncomingServer.cpp
3 	XUL	NS_InvokeByIndex	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp
4 	XUL	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)	js/xpconnect/src/XPCWrappedNative.cpp
5 	XUL	XPC_WN_GetterSetter(JSContext*, unsigned int, JS::Value*)	js/xpconnect/src/xpcprivate.h
6 	XUL	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct)	js/src/jscntxtinlines.h 

bp-b9a5201c-cfd9-4ec7-8158-de47a2140724 TB31.0

[1] https://crash-stats.mozilla.com/report/list?signature=nsCOMPtr_base%3A%3Aassign_with_AddRef%28nsISupports*%29+|+nsImapIncomingServer%3A%3AGetMsgFolderFromURI%28nsIMsgFolder*%2C+nsACString_internal+const%26%2C+nsIMsgFolder**%29&product=Thunderbird&query_type=is_exactly&range_unit=weeks&process_type=any&hang_type=any&date=2014-08-20+23%3A00%3A00&range_value=4#tab-reports

Comment 1

3 years ago
Seeing frequently (i.e. multiple times per day) on 42.0a2

e.g: https://crash-stats.mozilla.com/report/index/bfbb28a8-269b-4d4a-ae43-3641c2150911

Frame 	Module 	Signature 	Source
0 	XUL 	nsCOMPtr_base::assign_with_AddRef(nsISupports*) 	xpcom/glue/nsCOMPtr.cpp
1 	XUL 	nsImapIncomingServer::GetMsgFolderFromURI(nsIMsgFolder*, nsACString_internal const&, nsIMsgFolder**) 	/builds/slave/tb-c-aurora-m64-ntly-000000000/build/objdir-tb/x86_64/dist/include/nsCOMPtr.h:549
2 	XUL 	nsImapIncomingServer::SetDeleteModel(int) 	/builds/slave/tb-c-aurora-m64-ntly-000000000/build/mailnews/imap/src/nsImapIncomingServer.cpp:361
3 	XUL 	NS_InvokeByIndex 	xpcom/reflect/xptcall/md/unix/xptcinvoke_x86_64_unix.cpp
4 	XUL 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
5 	XUL 	XPC_WN_GetterSetter(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/xpcprivate.h
6 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
Version: 31 → 34

Comment 2

3 years ago
apols; accidentally changed version; changing back.
Version: 34 → 31

Updated

3 years ago
Crash Signature: [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsImapIncomingServer::GetMsgFolderFromURI(nsIMsgFolder*, nsACString_internal const&, nsIMsgFolder**)] → [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsImapIncomingServer::GetMsgFolderFromURI(nsIMsgFolder*, nsACString_internal const&, nsIMsgFolder**)] [@ nsCOMPtr_base::assign_with_AddRef | nsImapIncomingServer::GetMsgFolderFromURI]
(Reporter)

Comment 3

2 years ago
(In reply to Calum Mackay from comment #1)
> Seeing frequently (i.e. multiple times per day) on 42.0a2

Calum,
that crash has stopped for you?

(although I see you have different crashes more recently like bp-a026b06c-079a-4038-9c16-1743b2160315
and bp-86d2d4da-734c-4cb8-b608-519442160416 )
Flags: needinfo?(calum.mackay)

Comment 4

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #3)
> (In reply to Calum Mackay from comment #1)
> > Seeing frequently (i.e. multiple times per day) on 42.0a2
> 
> Calum,
> that crash has stopped for you?
> 
> (although I see you have different crashes more recently like
> bp-a026b06c-079a-4038-9c16-1743b2160315
> and bp-86d2d4da-734c-4cb8-b608-519442160416 )

No, I'm not seeing the regular crashes like I used to --- that stopped quite some time ago, fortunately; I should have updated here.

I do see an occasional crash when shutting down, but that's about all these days (thanks).
Flags: needinfo?(calum.mackay)
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) [except some obsolete <39 versions, no crashes starting since 39 version].
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

a year ago
This still occurs https://crash-stats.mozilla.com/search/?signature=~GetMsgFolderFromURI&date=%3E%3D2017-03-12T23%3A29%3A13.000Z&date=%3C2017-03-26T23%3A29%3A13.000Z&_sort=-date&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature

<name omitted> | nsImapIncomingServer::GetMsgFolderFromURI 
bp-ec598c4f-f1a4-4d44-9c09-b21442170326
Status: RESOLVED → REOPENED
Crash Signature: [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsImapIncomingServer::GetMsgFolderFromURI(nsIMsgFolder*, nsACString_internal const&, nsIMsgFolder**)] [@ nsCOMPtr_base::assign_with_AddRef | nsImapIncomingServer::GetMsgFolderFromURI] → [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsImapIncomingServer::GetMsgFolderFromURI(nsIMsgFolder*, nsACString_internal const&, nsIMsgFolder**)] [@ nsCOMPtr_base::assign_with_AddRef | nsImapIncomingServer::GetMsgFolderFromURI] [@ <name &hellip;
Resolution: WORKSFORME → ---
Summary: crash in nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsImapIncomingServer::GetMsgFolderFromURI(nsIMsgFolder*, nsACString_internal const&, nsIMsgFolder**) → crash in nsImapIncomingServer::GetMsgFolderFromURI [Mac]
You need to log in before you can comment on or make changes to this bug.